[MonoDevelop] Gtk# project with parallel mono environment

Michael Hutchinson m.j.hutchinson at gmail.com
Tue Jun 1 22:45:45 EDT 2010

On Tue, Jun 1, 2010 at 9:44 AM, Nicholas Frechette <zeno490 at gmail.com> wrote:
> Hi, I'm on ubuntu 9.10 and i'm trying to create a gtk# project.
> I've installed mono 2.6 from sources in a parallel environment as per:
> http://patrick.qmtech.net/blog/?p=14
> After wards, i've built/installed from source the following using the mono
> 2.6 environment (in order listed):
> mono-addins 0.4
> gtk# 2.12.10 (i've tried with 2.12.9 as well with the same result)
> monodevelop 2.2.2 (I also tried trunk a few days ago and the same issue
> would happen)
> I launch monodevelop using the 2.6 mono environment and I get the following:
> Upon launching, I get a dialog telling me an addin is having problems but
> does not list a name, if i expand it, i see:
> Error: Error while getting object for node in path
> '/MonoDevelop/Core/PlatformService'.
> Exception: System.TypeLoadException: Could not load type
> 'MonoDevelop.Platform.Gnome' from assembly 'GnomePlatform, Version=,
> Culture=neutral, PublicKeyToken=null'.
> Coming from Mono.Addins.TypeExtensionNode.CreateInstance

My guess would be that you're running into

I.e. you were able to build the GNOME platform addin, because the
gnome# assemblies are discoverable via pkg-config at compile-time, but
they're not in the GAC, so it fails to load at runtime.

You might want to try setting MONO_GAC_PREFIX -

Michael Hutchinson

More information about the Monodevelop-list mailing list