[MonoDevelop] Gtk# project with parallel mono environment

Nicholas Frechette zeno490 at gmail.com
Tue Jun 1 09:44:16 EDT 2010

Hi, I'm on ubuntu 9.10 and i'm trying to create a gtk# project.
I've installed mono 2.6 from sources in a parallel environment as per:
After wards, i've built/installed from source the following using the mono
2.6 environment (in order listed):
mono-addins 0.4
gtk# 2.12.10 (i've tried with 2.12.9 as well with the same result)
monodevelop 2.2.2 (I also tried trunk a few days ago and the same issue
would happen)

I launch monodevelop using the 2.6 mono environment and I get the following:
Upon launching, I get a dialog telling me an addin is having problems but
does not list a name, if i expand it, i see:

Error: Error while getting object for node in path
Exception: System.TypeLoadException: Could not load type
'MonoDevelop.Platform.Gnome' from assembly 'GnomePlatform, Version=,
Culture=neutral, PublicKeyToken=null'.
Coming from Mono.Addins.TypeExtensionNode.CreateInstance

Choosing yes to continue anyways loads the IDE and everything seems to work
fine as far as I can tell except the gtk# portion.
If I create a new test gtk# project, making sure to select the gtk# version
2.12, project creation is successful.
Now the generated project does not build as per line: MainWindow.cs, line 8
(Build() doesn't not exist)
If I comment the line and hook manually the onDeleteEvent, the test window
works fine and I can close it as well.
The MainWindow designer gui portion does not get generated under the User
Interface section however, meaning I cannot open it. Adding a new dialog to
the project will terminate monodevelop. No error window is shown.

Any ideas of what I can try to fix this?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/monodevelop-list/attachments/20100601/8cd322a3/attachment.html 

More information about the Monodevelop-list mailing list