[MonoDevelop] xsp2 web server cannot be started (but it has started??)

Chris Howie cdhowie at gmail.com
Fri Jul 10 08:54:26 EDT 2009

On Fri, Jul 10, 2009 at 8:43 AM, clemenslinders<clemenslinders at yahoo.com> wrote:
> I run XSP 2.0 Test Web Server
> (wether I run XSP 2.0 Index page or not, that doesn't matter)
> The DOS-screen for the XSP 2.0 Test Web Server has the following text:
> Mono version Build 1
> Prepending 'C:\Progr~1\Mono-2~1.1\bin' to PATH
> xsp2
> Listening on address:
> Root directory: C:\Progra~1\Mono-2~1.1\lib\xsp\test
> Listening on port: 8080(non-secure)
> Hit return to stop the server.
> Aplication_Start
> (I don't know if the Listen address of needs to be changed and if so
> how can it be changed) simply means "all IP addresses" so this indicates that the
server will accept connections on any of the network interfaces on
your box.  This is fine as long as you are suitable firewalled or
behind some router so that port 8080 is not exposed to the public

> I startup MonoDevelop, I open a aspx.net project created in VS C# 2005. And
> when I choose RUN I get the error xsp2 web server cannot be started (where
> the window for the XSP 2.0 Test Web Server is still open and doesn't show an
> error). PS compiling the project is no problem.
> I hope someone can tell me if I need to do something or if I'm doing
> something wrong.

It sounds like you are running the xsp2 server without specifying a
website to run, which seems pointless.  Then you are asking
MonoDevelop to run a project.  When you do this, it tries to start an
instance of xsp2 itself, but since port 8080 is already in use, this

Try running your solution in MD without xsp2 already running.

Chris Howie

More information about the Monodevelop-list mailing list