[MonoDevelop] Code completion stopped working, no apparent reason

Mário Duarte da Cruz duartecruz at gmail.com
Sat Sep 30 21:50:18 EDT 2006

The problem was pinpointed to the EditActionCollection class.

The "state" argument of the GetAction method has a default value of 8192
when no modifier keys are active, and so the action.State ==
filteredState condition was always false.

Considering that this issue seems to be affecting only me, this is
probably an abnormal behavior, maybe due to some very recent and
possibly buggy version of gtk installed on the system.

Anyway, the problem was solved by applying the attached patch. I believe
the patched version is the formally correct way of expressing the
desired condition. It is left for consideration by any developer that
may be lurking the list.

Best regards,

Duarte Cruz

Mário Duarte da Cruz wrote:
> Running version 0.12 under Gentoo. Code completion just stopped working
> out of the blue - or after some unknown and therefore impossible to
> backtrack update to the system. I've rebuilt both monodevelop and its
> supporting libs a dozen times by now. Cleared all configuration files,
> tried reverting to previous versions, all to no avail.
> The code completion data is created when need be, but both contextual
> and alt+space help are never available. And no errors are printed to the
> console from where monodevelop is being run.
> Has this happened to anyone, is there a quick/simple/obvious solution[1]
> or will I have to dive in the code and (try to) find the source of this
> annoying bug?
> Best regards,
> Duarte Cruz
> [1] Yes, I've checked the option in the preferences, and the XML config
> file confirms it.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: codecompletion-fix.diff
Type: text/x-patch
Size: 597 bytes
Desc: not available
Url : http://lists.ximian.com/pipermail/monodevelop-list/attachments/20061001/9b65744b/attachment.bin 

More information about the Monodevelop-list mailing list