[MonoDevelop] cs syntax highlighting does not work for me

John Luke jluke@users.sourceforge.net
Wed, 31 Mar 2004 00:01:59 -0500


On Tue, 2004-03-30 at 12:49 +0200, rainer@4950.net wrote:
> Hi 
> I tried now everything. I installed gtksourceview-sharp from suse9 rpm I have
> xd-unstable (gnome-2.6) and mono-0.31. In addition to that I compiled gtk-sharp
> from cvs, gtksourceview-sharp from cvs, and monodevelop latest snapshots.
> Syntax highlighting works for aspx files (if the <html> is at latest in the
> second line of the source). However, for cs files it simply does not work. I
> launched gnome-file-types-properties and set the mime type for text/x-csharp (or
> whatever was on the faq). But still no highlighting. The same happens for
> monodevelop-0.1.
> I dont know what to do anymore. Can anyone make a suggestion?
If you look at a .cs file in nautilus does the type say text/x-csharp?
If not the mimetype isn't set correctly for some reason.  Maybe you need
to manually run update-mime-database after editing it.

> By the way, I have another problem aswell. If I am running KDE (3.2.1)
> monodevelop is really SLOW!! However, if I run xd-unstable (gnome 2.6) it is
> really fast.
I can't think of any reason it would be slower in KDE.