[Mono-list] Running mod_mono_server to use tcp fails to run

Alex Villací­s Lasso avillaci at ceibo.fiec.espol.edu.ec
Tue Jun 17 11:12:20 EDT 2008

monoOnTcp escribio':
> Hi,
> I have been running mod_mono_server using unix socket and communicating to
> apache. I have been trying to use tcp instead of unix sockets but
> mod_mono_server fails to run with the following error message:
> ---------
> mod-mono-server2
> Handling exception type FormatException
> Message is Input string was not in a correct format.
> IsTerminating is set to True
> ---------
> The command line that i used is :
>  /usr/bin/mono /usr/lib/mono/2.0/mod-mono-server2.exe --applications
> /ncs:/opt/njini/ncs --nonstop --address --port xxx where i tried
> different combinations of the port number
> Am i running it correctly? if not, then what will be the appropriate
> command?
> I have also tried to use it with apache by using the config file .
> my config file is 
> -------------
> Alias /myvirt "/opt/myProd/mydir"
> AddMonoApplications default "/myVirt:/opt/myProd/mydir"
> MonoServerPath default /usr/bin/mod-mono-server2
> MonoRunXSP false
> MonoListenPort myvirt 7000
> PassEnv
> <Location /ncs>
>     SetHandler mono
> </Location>
> -------
> I even added MonoListenAddress directive but with no success.
>  [error] mod_mono: connect error (Invalid argument). Address:
> Port: 7000
> Please let me know if you need further inputs or the debug traces.
> Thanks,
I had the exact same problem on Mono 1.9.1 . It is actually a known bug 
in mod_mono, and is reportedly already fixed in SVN. See my report: 
https://bugzilla.novell.com/show_bug.cgi?id=392228 (patch included).

You might also run into the following bug: 
https://bugzilla.novell.com/show_bug.cgi?id=392235 , reportedly also 
fixed in SVN, which interferes with attempts to place the primary mono 
server as TCP. This report also has a patch included.

perl -e '$x=2.4;print sprintf("%.0f + %.0f = %.0f\n",$x,$x,$x+$x);'

More information about the Mono-list mailing list