[Mono-list] Running mod_mono_server to use tcp fails to run

monoOnTcp amit_kachroo at yahoo.com
Tue Jun 17 08:41:24 EDT 2008

I have been running mod_mono_server using unix socket and communicating to
apache. I have been trying to use tcp instead of unix sockets but
mod_mono_server fails to run with the following error message:
Handling exception type FormatException
Message is Input string was not in a correct format.
IsTerminating is set to True
The command line that i used is :
 /usr/bin/mono /usr/lib/mono/2.0/mod-mono-server2.exe --applications
/ncs:/opt/njini/ncs --nonstop --address --port xxx where i tried
different combinations of the port number
Am i running it correctly? if not, then what will be the appropriate

I have also tried to use it with apache by using the config file .
my config file is 
Alias /myvirt "/opt/myProd/mydir"
AddMonoApplications default "/myVirt:/opt/myProd/mydir"
MonoServerPath default /usr/bin/mod-mono-server2

MonoRunXSP false
MonoListenPort myvirt 7000
<Location /ncs>
    SetHandler mono
I even added MonoListenAddress directive but with no success.

 [error] mod_mono: connect error (Invalid argument). Address:
Port: 7000

Please let me know if you need further inputs or the debug traces.


View this message in context: http://www.nabble.com/Running-mod_mono_server-to-use-tcp-fails-to--run-tp17896801p17896801.html
Sent from the Mono - General mailing list archive at Nabble.com.

More information about the Mono-list mailing list