[Mono-list] build problem with Mono 0.24

Randy J. Ray rjray@blackperl.com
Wed, 7 May 2003 21:03:44 -0700

>   I can't build with the 0.24 release. When I run configure, it inserts
> this little complaint into config.h:
>    #error configure failed to discover size of unix socket path
> An inspection of config.log shows that the problem appears to be a
> missing library file (libsocket, to be precise).

Odd. I've built 0.24 on both RH 8.0 and RH 9. I haven't tried it on 7.3 yet. 
Are you sure that libsocket has anything to do with it? The string "libsocket" 
doesn't seem to appear anywhere in my configure or config.log. There's a check 
in configure.in, but the only match for libsocket on my filesystem is 
/usr/local/lib/libsocket++.so and family.

>   Has anyone else figured out a solution to this? I'm running Red Hat
> 8.0 with the latest updates. In lieu of a solution, if someone could
> indicate what the value of MONO_SIZEOF_SUNPATH is for their RH 8.0
> system, that would be great.

On my system, it's 108.

Randy J. Ray        Campbell, CA    http://www.rjray.org    rjray@blackperl.com

Silicon Valley Scale Modelers: http://www.svsm.org