[Mono-list] build problem with Mono 0.24

Jim Kerr jbkerr@sonic.net
07 May 2003 21:41:49 +0800

Thanks for the help! It helped me to hit the next wall. When compiling
mono, this error appears:

gcc -g -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations
-Wstrict-prototypes -Wmissing-prototypes -Wnested-externs
-Wpointer-arith -Wno-cast-qual -Wcast-align -Wwrite-strings -o pedump
pedump.o -Wl,--export-dynamic  ./.libs/libmetadata.al
../io-layer/.libs/libwapi.al ../utils/.libs/libmonoutils.al
-lgmodule-2.0 -lglib-2.0 -lm /usr/local/lib/libgc.so -ldl -lnsl
-lpthread -lrt -Wl,--rpath -Wl,/usr/local/lib -Wl,--rpath
../io-layer/.libs/libwapi.al(timed-thread.lo): In function
/usr/src/mono-0.24/mono/io-layer/timed-thread.c:88: undefined reference
to `gc_thread_vtable'
../io-layer/.libs/libwapi.al(timed-thread.lo): In function
/usr/src/mono-0.24/mono/io-layer/timed-thread.c:126: undefined reference
to `gc_thread_vtable'
collect2: ld returned 1 exit status
make[3]: *** [pedump] Error 1
make[3]: Leaving directory `/usr/src/mono-0.24/mono/metadata'

  The only reference I can find in the sources to gc_thread_vtable is in
mono/metadata/gc.c, where this appears:

        gc_thread_vtable = &mono_gc_thread_vtable;

  Not sure where to go after this... who defines WITH_INCLUDED_LIBGC?

Jim Kerr
Agilent Technologies, Inc.
Santa Rosa, CA

On Thu, 2003-05-08 at 12:03, Randy J. Ray wrote:
> >   I can't build with the 0.24 release. When I run configure, it inserts
> > this little complaint into config.h:
> > 
> >    #error configure failed to discover size of unix socket path
> > 
> > An inspection of config.log shows that the problem appears to be a
> > missing library file (libsocket, to be precise).
> Odd. I've built 0.24 on both RH 8.0 and RH 9. I haven't tried it on 7.3 yet. 
> Are you sure that libsocket has anything to do with it? The string "libsocket" 
> doesn't seem to appear anywhere in my configure or config.log. There's a check 
> in configure.in, but the only match for libsocket on my filesystem is 
> /usr/local/lib/libsocket++.so and family.
> >   Has anyone else figured out a solution to this? I'm running Red Hat
> > 8.0 with the latest updates. In lieu of a solution, if someone could
> > indicate what the value of MONO_SIZEOF_SUNPATH is for their RH 8.0
> > system, that would be great.
> On my system, it's 108.
> Randy
> -- 
> """""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""
> Randy J. Ray        Campbell, CA    http://www.rjray.org    rjray@blackperl.com
> Silicon Valley Scale Modelers: http://www.svsm.org