[Mono-dev] Problems using Tao Framework

Marcos Cobeña Morián marcoscobena at gmail.com
Sun Sep 30 09:26:10 EDT 2007

Hi Bart,

I've never played with Tao, but from your exception thrown it's likely
Mono's looking for "GLUT" file (without extension) and such doesn't
exist (a P/Invoke issue).

Some light here:



2007/9/30, Bart Masschelein <masschel at gmail.com>:
> Hi all,
> I'm trying to use the Tao Framework on mono 1.2.5 for osx. I'm using
> the latest from svn, as this one does not give problems when using
> the build scripts. Everything goes fine, until I want to run the
> examples. For the CG examples I get
>   System.DllNotFoundException: /System/Library/Frameworks/
> GLUT.framework/GLUT
> and for the SDL examples I get similar error messages. I'm sure I
> have both frameworks installed, and at the indicated location. It's
> true however, that these directories don't contain .dylib files. I've
> read in another post that the PATHor LD_LIBRARY_PATH environment
> variable should be set correctly, but where are the libraries the
> actually located? Anyway, a previous post (http://
> cjcollier.livejournal.com/122002.html) shows that nothing more should
> be done, and it should be automagically done.
> I also tried to use the darwin port glut, and changing my .config
> file accordingly, but with the same error (for glut then of course).
> Anyone got lucky on this issue, and could shed some light here?
> Thanks,
> Bart
> _______________________________________________
> Mono-devel-list mailing list
> Mono-devel-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-devel-list

Marcos - http://www.youcannoteatbits.org

More information about the Mono-devel-list mailing list