[Mono-dev] OpenTF Question

Jerry Houston jerry at EffJayAre.net
Mon Dec 17 21:17:59 EST 2007

I hope this is on-topic here -- it's my first post to a mono list, and I
don't know of any that's specific to OpenTF.  However, I figured other
developers here are probably using it, and might be able to help me out. 

I'm a professional .NET developer by day, and a Linux enthusiast the
rest of the time.  I'm pretty amazed that I can so easily port a utility
that I built to run on Windows, just by copying the solution from my
XP-Pro machine to my openSuSE machine and rebuilding it with mono.  Now
that I'm working in this environment, source control is going to be an
issue for me, and I was excited to find out about OpenTF.

I downloaded the Win32 client, and tried to issue a few commands against
our TFS server at work, but I got stopped pretty early on because of our
domain naming convention.  Because I'm in our company's Bothell
location, our machine names here all start with "bot-".   So our TFS
server, for example, is called "bot-VSTF."

When I try to use OpenTF to get a list of workspaces on that server, I
get an error telling me that it doesn't understand "-VSTF."  Apparently
it's consdering the "-" to be a switch character, which makes sense,
however I should be able to enclose an argument in quotes to get around
that.  Not so, in this case. 

I've tried using




with exactly the same results.  OpenTF STILL thinks I'm passing it a
parameter called "VSTF" that it doesn't recognize.

Am I missing something obvious here?  Thanks in advance to anyone who
can help!

    Jerry in Bothell, WA

More information about the Mono-devel-list mailing list