[Mono-devel-list] Re: Mono 1.1.4 - will build but won't install

Paul paul at all-the-johnsons.co.uk
Sat Feb 19 12:12:32 EST 2005


>I didn't build from cvs, so I actually used ./configure, but yes, I did:
>./configure --prefix=/usr
>sudo make install
>In Ubuntu, the root account is disabled so generally we always use sudo.

Sounds pretty stupid to me (from a security point of view - it's almost
as insane as Linspire doing *everything* as root!)

>However, for other reasons I enabled the root account. So, logging into 
>root (with su), I also tried "make install" and got the same error.
>... which is quite odd now that I think about it... Why would it be 
>complaining about /usr/local/lib when I configured using /usr? 

It shouldn't. Out of interest, which version of automake and autoconf
are you using there? It sounds like something is a bit bust. Have you
made it before in /usr/local?

>I originally tried configuring to usr/local/ but had some weird build 
>errors so I redownloaded the source from mono-project.com/downloads and 
>then built against /usr and it built without any problems.

It sounds like there is some left over from the previous build to me.
Check /usr/local/lib vs /usr/lib to see if any of the mono libs have
been put into /usr/local/lib. If they have, hose them.


"I like blinking me" - Helen, Big Brother 2 contestant
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.ximian.com/pipermail/mono-devel-list/attachments/20050219/c90297d0/attachment.bin 

More information about the Mono-devel-list mailing list