[Mono-devel-list] Re: Mono 1.1.4 - will build but won't install

Matt Philmon mattisking at pobox.com
Sat Feb 19 11:34:30 EST 2005

Hey Paul,

I didn't build from cvs, so I actually used ./configure, but yes, I did:
./configure --prefix=/usr
sudo make install

In Ubuntu, the root account is disabled so generally we always use sudo. 
However, for other reasons I enabled the root account. So, logging into 
root (with su), I also tried "make install" and got the same error.

... which is quite odd now that I think about it... Why would it be 
complaining about /usr/local/lib when I configured using /usr? If it was 
going to complain, you'd think it would complain about /usr/lib. Weird. 
I originally tried configuring to usr/local/ but had some weird build 
errors so I redownloaded the source from mono-project.com/downloads and 
then built against /usr and it built without any problems.


>Message: 7
>Did you define anything for prefix when you ran autogen.sh? It should
>have been /usr for /usr/lib or left out for /usr/local/lib.
>Other than that, do you get the same error is you actually change to su
>then do the make install?

More information about the Mono-devel-list mailing list