[Mono-devel-list] Re: Mono 1.1.4 - will build but won't install

Raja R Harinath rharinath at novell.com
Mon Feb 21 01:34:49 EST 2005


Matt Philmon <mattisking at pobox.com> writes:

> I didn't build from cvs, so I actually used ./configure, but yes, I did:
> ./configure --prefix=/usr
> make
> sudo make install
> In Ubuntu, the root account is disabled so generally we always use
> sudo. However, for other reasons I enabled the root account. So, logging
> into root (with su), I also tried "make install" and got the same error.
> ... which is quite odd now that I think about it... Why would it be
> complaining about /usr/local/lib when I configured using /usr? If it was
> going to complain, you'd think it would complain about
> /usr/lib. Weird. I originally tried configuring to usr/local/ but had
> some weird build errors so I redownloaded the source from
> mono-project.com/downloads and then built against /usr and it built
> without any problems.

You probably ran


and then, suddenly decided to change the prefix and ran

  ./configure --prefix=/usr
  make install

If the library didn't change between the two invocations of configure,
the old prefix will be stored in the .la file, and will lead to this

- Hari

More information about the Mono-devel-list mailing list