[MonoDevelop] Stetic GUI Designer Manual

TheWind777 TheWind777 at hotmail.com
Fri Jul 3 12:26:01 UTC 2015

Getting back to you again.

I tried saving out the image at 64x64, 48x48, 32x32 and 16x16 in both png
and svg formats.

Again, when I would add them all as Build ->EmbeddedResource, then add them
to the Icon list with a Single image, then use that icon on a button; did
the same thing each time... 

All formats would show the icon properly in the Icon window; but then just
show the name of the Icon on the button instead of the picture (and icon
name) as the built-in Icons do.

So, it seems like it understands the formats PNG, ICO and SVG; yet all
formats do exactly the same thing when you try importing them in as a Stock
Icon from Resources no matter whether they are off-sizes, or defined good
sizes (64x64, 48x48, 32x32, 16x16), no matter whether they are single image
PNG (of all those sizes), single image SVG (of all those sizes) or
multiple-image ICO (of all those sizes).

Another annoying thing that would occur is... if you were to use an image,
then delete that image from the Icon list and from the Program list... 
you'd still get an error as if it were trying to compile that old (now gone)
picture. I found that the offending document which was causing this was in
the Project folder's obj/x86/Debug and/or obj/x86/Release folder with a name
of projectname.gtk-gui.gui.stetic

You could edit that file, search for the offending missing image, and
replace it with a resource:good.img and the problem would go away.

I also searched in the same file and found that, when I used their stock
gtk-floppy image it included it in the file as <property

So, again, got no new clues about where the Stock Ids are kept. They might,
even, be embedded inside the /usr/bin/mono executable; so we might never
know what format the Stock Items are expected to be in to get them to

I suspect it is a layered image that contains all four of the sizes,
one-per-layer; probably as a layered PNG format file. It's just that the
order of those layers might be important, and how many layers there are
might be important.

Even if I succeed, however, in getting an icon to go onto a button. It still
puts the icon PLUS a name onto the button even though you are asking it to
just put the Stock Icon. (It shows a symbol of a floppy disk, then it says
'Floppy' to the right of it).

I see no way to get it to stop putting the name there.

View this message in context: http://mono.1490590.n4.nabble.com/Stetic-GUI-Designer-Manual-tp4666277p4666285.html
Sent from the Mono - MonoDevelop IDE mailing list archive at Nabble.com.

More information about the Monodevelop-list mailing list