[MonoDevelop] Unable to Create Solutions or open Files in Mono Dev 2.4 or 2.6 on Windows 7 x64

dev 13 unitydev13 at gmail.com
Mon Sep 26 05:47:14 EDT 2011

Strangely enough for me the latest (2.8 msi trunk?) won't even run at all
after installing and trying to execute the exe. It just does nothing. Doesnt
throw an error, doesnt show a load screen, nothing. Dbl click. Nothing.

With 2.6 stable install I can open a solution. When I try to open any file
it throws this exception. Exception for creating projects or new files as

I have also tried running everything as Admin, and disabling UAC and any
Virus/Security software. Doesnt do a thing.

Are there are any other logs or trace methods I can use to get someone a

I may end up loading this on a VM..  but id like to get it working on my
base machine if possible..

I also tried downloading the source to debug but had too many errors and
missing references (even after following the instructions on building the
source in visual studio) and I just didnt have the time to get into it

I can try and get you a screencast but it really won't show much.

I am running the OS off an SSD drive and am pointing most library folders
and user folder to the secondary storage drive. I have hardware
virtualization enabled and run VMs. Other than this there isnt really
anything else too different from the standard windows 7 x64 install.


On Mon, Sep 26, 2011 at 5:05 AM, Alan <alan.mcgovern at gmail.com> wrote:

> Would you be able to do a screencast of the exact steps you follow to
> replicate this error with 2.6? Alternatively, could you try the 2.8 beta
> series and see if the same issue manifests there and if so screencast that?
> I've never heard of this issue and have no idea how to replicate it. Is
> there anything unusual about your setup which might trigger unusual
> behaviour in MD?
> Alan.
> On 26 September 2011 03:23, dev 13 <unitydev13 at gmail.com> wrote:
>> I am trying to develop in Unity and Mono and have been unsuccessful in
>> getting MonoDevelop to work correctly.
>> I have searched all over but have not found a solution and have been
>> unable to resolve this issue. Any help is appreciated. I have been unable to
>> develop in MonoDevelop. It throws exceptions every time I try to open a file
>> or create a solution. Unable to use new or previously existing solutions.
>> Is there anything I can do to solve this issue?
>> Tried clean installs of Both Unity and MonoDevelop. I am able to open them
>> fine in text editors and visual studio, but I want to be able to debug and
>> use MonoDevelop.
>> Windows 7 x64,
>> Latest Stable versions of Unity and MonoDevelop
>> Let me know if there is any other information, errors, or logging I would
>> be able to provide. I am green to Mono and Unity.
>> Thanks again.
>> Sample Exception:
>> Error:
>> The file 'F:\**.cs' could not be opened. Exception has been thrown by the
>> target of an invocation.
>> Details:
>> System.Reflection.TargetInvocationException: Exception has been thrown by
>> the target of an invocation. ---> System.ArgumentException: The path is not
>> of a legal form.
>>    at System.IO.Path.NormalizePath(String path, Boolean fullCheck, Int32
>> maxPathLength)
>>    at System.IO.Path.GetFullPathInternal(String path)
>>    at System.IO.Path.GetFullPath(String path)
>>    at MonoDevelop.Ide.Gui.Components.FileBrowser.set_CurrentDir(String
>> value)
>>    at MonoDevelop.Ide.Gui.Components.FileBrowser..ctor()
>>    at MonoDevelop.Ide.Gui.Pads.FileScout..ctor()
>>    --- End of inner exception stack trace ---
>>    at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean
>> publicOnly, Boolean noCheck, Boolean& canBeCached,
>> RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck)
>>    at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean
>> skipCheckThis, Boolean fillCache)
>>    at System.RuntimeType.CreateInstanceDefaultCtor(Boolean publicOnly,
>> Boolean skipVisibilityChecks, Boolean skipCheckThis, Boolean fillCache)
>>    at System.Activator.CreateInstance(Type type, Boolean nonPublic)
>>    at Mono.Addins.RuntimeAddin.CreateInstance(String typeName, Boolean
>> throwIfNotFound)
>>    at MonoDevelop.Ide.Codons.PadCodon.CreatePad()
>>    at MonoDevelop.Ide.Codons.PadCodon.InitializePadContent(IPadWindow
>> window)
>>    at MonoDevelop.Ide.Gui.PadWindow.CreateContent()
>>    at MonoDevelop.Ide.Gui.PadWindow.get_Content()
>>    at MonoDevelop.Ide.Gui.Pad.get_Content()
>>    at MonoDevelop.Ide.Gui.Workbench.GetPad[T]()
>>    at MonoDevelop.SourceEditor.SourceEditorView..ctor()
>>    at
>> MonoDevelop.SourceEditor.SourceEditorDisplayBinding.CreateContent(FilePath
>> fileName, String mimeType, Project ownerProject)
>>    at MonoDevelop.Ide.Gui.LoadFileWrapper.Invoke(String fileName)
>> _______________________________________________
>> Monodevelop-list mailing list
>> Monodevelop-list at lists.ximian.com
>> http://lists.ximian.com/mailman/listinfo/monodevelop-list
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/monodevelop-list/attachments/20110926/0239a2f7/attachment-0001.html 

More information about the Monodevelop-list mailing list