[MonoDevelop] Monodevelop broken after upgrade to Ubuntu 11.10

Jim Orcheson jim at va3hj.ca
Tue Oct 18 07:58:29 EDT 2011

Hi Derek,

I am also having problems with MonoDevelop after upgrading to Ubuntu 
11.10. I do not get "no C# compiler for .Net 3.5" but there are no Gtk# 
libraries built for .Net 3.5 anymore. I changed the runtime version to 
Mono/.Net 4.0 to get my projects to build.

I still have a problem with NUnit. As soon as I attempt to run tests, I 
get "Internal Error. NullReferenceException at 
System.Runtime.Remoting.Proxies.RealProxy rp, IMessage msg, 
System.Exception& exc,
System.Object[]& out_args) [0x0000] in <filename unknown>:0"

I found that a number of packages have been removed and had to be 
installed after the upgrade, but I still have not found anything that 
will fix the NUnit problem.


On 11-10-18 05:18 AM, Derek JW Cahusac de Caux wrote:
> Upgrading from Ubuntu 11.04 to 11.10 has been far from smooth over the 
> past few days - just thought I'd share a few notes on my 'progress' so 
> far, in case this helps any others...
> Also any pointers on how to get Monodevlop building/compiling again 
> would be appreciated - Ubuntu upgraded my version from 2.4 to 2.6 (and 
> Mono to 2.10)
> thanks, Derek
> Notes:
> Problems after upgrading from Ubuntu 11.04 to 11.10
> 14th -17th October 2011
> 1. Performance -- very very very slow -- everything was a dog
> >> installed Gnome shell and changed themes to Adawaita -- better
> >> installed Chrome as Firefox was repeatedly hanging
> >> using the Gnome desktop (you need to RIGHT click on the cog in the 
> Login box after starting the PC to select Gnome) and Chrome has made 
> life bearable, but it was 'hell' for 3 days whilst I figured this out 
> -- not much help on the net/forums etc
> 2. Still broken -- myRSS (own C# news feed reader) not working - 
> running from Terminal shows numerous error messages 'missing method 
> System.Type' and in MonoDevelop it seems that all the target 
> assemblies are now wrong!!
> 3. Still broken -- MonoDevelop -- attempt to build fails with 'no C# 
> compiler for .NET/3.5' !! this is the pits...
> 4. Still broken -- network printing -- other (Windows) PCs on the home 
> network cannot print
> 5. Fixed -- LibreOffice Calc -- this would just crash on start-up, 
> after the start-up splash -- no error message -- Writer worked, as did 
> Draw (didn't try the others) -- running 'libreoffice --calc %U' from 
> Terminal at least showed an error message -- tried without the %U 
> parameter (which I assume is user, but could not confirm) also failed 
> -- finally one error message started to make sense, something about 
> 'another instance of LibreOffice is accessing your personal settings 
> which are locked' and that 'it's not safe for simultaneous access to 
> your settings -- do you want to continue, Yes or No' -- neither Yes or 
> No would work -- around this time also found that Nautilus (from 
> Places) would disappear on start-up, in the same way as Calc -- reboot 
> sorted this problem, Nautilus worked -- checking Syslog saw that 
> LibreOffice and Nautilus were SegFaulting -- rummaging around the file 
> system (now that Nautilus worked) I came across a '.lock' file in 
> /home/.libreoffice/3 -- this file showed the user as 'root' (not my 
> normal user) -- renamed this file to '.lockOLD' and, miracle of 
> miracles, Calc finally worked (and created another '.lock' file with 
> my usual user name).
> ======
> -- 
> Derek JW Cahusac de Caux
> _______________________________________________
> Monodevelop-list mailing list
> Monodevelop-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/monodevelop-list
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/monodevelop-list/attachments/20111018/f8e4acd8/attachment.html 

More information about the Monodevelop-list mailing list