[MonoDevelop] Monodevelop broken after upgrade to Ubuntu 11.10

Derek JW Cahusac de Caux derek at azuregulf.com
Tue Oct 18 05:18:26 EDT 2011

Upgrading from Ubuntu 11.04 to 11.10 has been far from smooth over the
past few days - just thought I'd share a few notes on my 'progress' so
far, in case this helps any others...

Also any pointers on how to get Monodevlop building/compiling again
would be appreciated - Ubuntu upgraded my version from 2.4 to 2.6 (and
Mono to 2.10)

thanks, Derek


Problems after upgrading from Ubuntu 11.04 to 11.10

14th -17th October 2011

1. Performance -- very very very slow -- everything was a dog
      >> installed Gnome shell and changed themes to Adawaita -- better
      >> installed Chrome as Firefox was repeatedly hanging
      >> using the Gnome desktop (you need to RIGHT click on the cog in
the Login box after starting the PC to select Gnome) and Chrome has made
life bearable, but it was 'hell' for 3 days whilst I figured this out --
not much help on the net/forums etc

2. Still broken -- myRSS (own C# news feed reader) not working - running
from Terminal shows numerous error messages 'missing method System.Type'
and in MonoDevelop it seems that all the target assemblies are now wrong!!

3. Still broken -- MonoDevelop -- attempt to build fails with 'no C#
compiler for .NET/3.5' !! this is the pits...

4. Still broken -- network printing -- other (Windows) PCs on the home
network cannot print

5. Fixed -- LibreOffice Calc -- this would just crash on start-up, after
the start-up splash -- no error message -- Writer worked, as did Draw
(didn't try the others) -- running 'libreoffice --calc %U' from Terminal
at least showed an error message -- tried without the %U parameter
(which I assume is user, but could not confirm) also failed -- finally
one error message started to make sense, something about 'another
instance of LibreOffice is accessing your personal settings which are
locked' and that 'it's not safe for simultaneous access to your settings
-- do you want to continue, Yes or No' -- neither Yes or No would work
-- around this time also found that Nautilus (from Places) would
disappear on start-up, in the same way as Calc -- reboot sorted this
problem, Nautilus worked -- checking Syslog saw that LibreOffice and
Nautilus were SegFaulting -- rummaging around the file system (now that
Nautilus worked) I came across a '.lock' file in /home/.libreoffice/3 --
this file showed the user as 'root' (not my normal user) -- renamed this
file to '.lockOLD' and, miracle of miracles, Calc finally worked (and
created another '.lock' file with my usual user name).

Derek JW Cahusac de Caux

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/monodevelop-list/attachments/20111018/8671defc/attachment.html 

More information about the Monodevelop-list mailing list