[MonoDevelop] with Xcode 4.1

Mark Smith mark at julmar.com
Wed Aug 24 16:08:42 EDT 2011

I'm trying out the 2.8 alpha of MonoDevelop with XCode.  I really like the new info.plist editor, very nice.  However, I got XCode 4.1 installed (it updated from the app store) and now I often get crashes switching to XCode from MD.  Here's the details:

ASSERTION FAILURE in /SourceCache/IDEInterfaceBuilder/IDEInterfaceBuilder-1617/Framework/Utilities/IBFoundationAdditions.m:1916
Details:  Both arguments are required
Function: NSString *IBRelativePath(NSString *, NSString *)
Thread:   <NSThread: 0x401bcfee0>{name = (null), num = 7}
Hints:   None
  0  0x000000010b7d5152 -[IDEAssertionHandler handleFailureInFunction:fileName:lineNumber:messageFormat:arguments:] (in IDEKit)
  1  0x000000010ae741bc _DVTAssertionHandler (in DVTFoundation)
  2  0x000000010ae84304 _DVTAssertionFailureHandler (in DVTFoundation)
  3  0x000000010e9084f3 IBRelativePath (in IDEInterfaceBuilderKit)
  4  0x000000010ea288e4 +[IBClassDescriptionSource(InstantiationConvenience) workspaceDocumentSourceIdentifierForInterfaceFile:inWorkspaceDocument:] (in IDEInterfaceBuilderKit)
  5  0x000000010ea2d2d8 -[IBClassDescriptionBasedClassProvider integratePartialDescriptionsFromFiles:inWorkspaceDocument:errorsPerFile:] (in IDEInterfaceBuilderKit)
  6  0x000000010ae227f9 __38-[DVTDispatchLock performLockedBlock:]_block_invoke_0 (in DVTFoundation)
  7  0x00007fff9487cafd _dispatch_barrier_sync_f_invoke (in libdispatch.dylib)
  8  0x000000010ae227a9 -[DVTDispatchLock performLockedBlock:] (in DVTFoundation)
  9  0x000000010ea3968b -[IBHeaderScanningClassProvider performBlockEnsuringNotCanceled:] (in IDEInterfaceBuilderKit)
 10  0x000000010ea3a853 __block_global_4 (in IDEInterfaceBuilderKit)
 11  0x00007fff9487a90a _dispatch_call_block_and_release (in libdispatch.dylib)
 12  0x00007fff9487c15a _dispatch_queue_drain (in libdispatch.dylib)
 13  0x00007fff9487bfb6 _dispatch_queue_invoke (in libdispatch.dylib)
 14  0x00007fff9487b7b0 _dispatch_worker_thread2 (in libdispatch.dylib)
 15  0x00007fff90eb83da _pthread_wqthread (in libsystem_c.dylib)
 16  0x00007fff90eb9b85 start_wqthread (in libsystem_c.dylib)

Is there a workaround for this? I.e. something I can change in my workflow?  I notice it often happens when I move from one project to another - it appears XCode is restoring the previous project on open (a feature I dislike immensely in Lion).  I'm not sure that has anything to do with the above issue, but I figured I'd mention it.



On Aug 24, 2011, at 3:01 PM, Oskar Berggren wrote:

> Odd numbers are development series, even numbers are intended as
> stable release series. The most stable version at this time, should by
> the theory of version numbers, be either the released 2.4, or 2.6 RC1.
> Reality is of course another matter.
> /Oskar
> 8/24 Matt Calder <mvcalder at gmail.com>:
>> Hi,
>> I'm not sure if this question was seen to be silly or people are just
>> busy. But I went ahead and installed the 2.5.93 branch hoping it would
>> fix the problem I was having with the 2.8 (or is it 2.7?) version.
>> Unfortunately, it did not. So I'll just mention it here. Both of these
>> newer versions (I had been on one of the 2.4 branches, sorry don't
>> know which) seem to have issues in the debugger. The hover no longer
>> reliably brings up the object inspection window. I guess the problem
>> could me in nunit or in mono:
>> $ mono --version
>> Mono JIT compiler version 2.11 ((no/7917753 Wed Mar 30 15:47:09 EDT 2011)
>> Copyright (C) 2002-2011 Novell, Inc and Contributors. www.mono-project.com
>>        TLS:           __thread
>>        SIGSEGV:       altstack
>>        Notifications: epoll
>>        Architecture:  amd64
>>        Disabled:      none
>>        Misc:          softdebug
>>        LLVM:          yes(2.8svn-mono)
>>        GC:            Included Boehm (with typed GC and Parallel Mark)
>> but it worked prior to the new monodevelop (2.5.93) install. I
>> probably will rollback to an earlier version and will post a reply
>> about where the break began.
>> If anyone understands the version naming conventions, and which
>> versions 2.5.x, 2.6, 2.7, or 2.8 are most current I'd appreciate a
>> reply here, thanks.
>> Matt
>> On Wed, Aug 24, 2011 at 8:27 AM, Matt Calder <mvcalder at gmail.com> wrote:
>>> Hi,
>>> I recently installed MD from the source on github, branch "master".
>>> When I run Help-About I see "Version 2.8 Alpha 1 (2.7)". The recent
>>> announcement was that "The MonoDevelop team is proud to announce the
>>> release of MonoDevelop 2.6
>>> Release Candidate 1 (2.5.93).". I see that on github there is a branch
>>> 2.5.93, and a branch 2.6.
>>> My questions are: between the branches "master", "2.5.93", and "2.6"
>>> what are the main differences, and which is to be preferred (and why)?
>>> And additionally, if someone could give some background on the
>>> plethora of version numbers that seem to be floating about (2.5.x,
>>> 2.6, 2.7, and 2.8), it would be very helpful.
>>> Thanks,
>>> Matt
>> _______________________________________________
>> Monodevelop-list mailing list
>> Monodevelop-list at lists.ximian.com
>> http://lists.ximian.com/mailman/listinfo/monodevelop-list
> _______________________________________________
> Monodevelop-list mailing list
> Monodevelop-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/monodevelop-list

More information about the Monodevelop-list mailing list