[MonoDevelop] monodevelop 2.4 debug/breakpoints issue Ubuntu 10.04

Mauri maurizio.laudone at tiscali.it
Wed Jul 14 02:24:00 EDT 2010

Hi all,
I was using Monodevelop 2.2 from the official Ubuntu repos and it worked
well enough. When I saw that 2.4 had been released I added the Badgerports
repo to my list and updated all there was to update on my system. Compiling
and running projects still works well and I love a lot of the changes, but I
cannot use the debugger. 

On a C# project the debugger seems to start but the breakpoints are never
reached and nothing happens (even though they are on lines where they should
most certainly be reached). If I start monodevelop from the command line,
when I start the debugger I get '## DebuggerServer started MDB version:
2-4-4' confirming that the debugger has started, but nothing happens, the
breakpoints are never reached and the program never completes its run.
On a C++ project it when I tried to debug, first monodevelop simply crashed
and on successive attempts nothing happens at  all. At command line I get
'OnTargetEvent, type - TargetExited' and nothing else happens.

Any idea what may be going wrong on my system or how to troubleshoot it?
Thanks for your help,

View this message in context: http://mono.1490590.n4.nabble.com/monodevelop-2-4-debug-breakpoints-issue-Ubuntu-10-04-tp2288347p2288347.html
Sent from the Mono - MonoDevelop IDE mailing list archive at Nabble.com.

More information about the Monodevelop-list mailing list