[MonoDevelop] Notes about Building MonoDevelop in MonoDevelop on Mac

Scott Willeke scott at willeke.com
Wed Jan 27 21:53:10 EST 2010

Thanks. I should have found the config and the doc. That makes life easier. Bug filed https://bugzilla.novell.com/show_bug.cgi?id=574595 I did confirm that the trunk version of MD was able to load the solution in spite of the policy setting.

I tried MacDebug and found MonoDevelop.GnomePlatform is still included in the solution config. Excluding it worked fine.

You guys are doing a fantastic job. I haven't tried out MD in approximately two years, it has come a long way. A real pleasure to use. I hope the perf will remain so great as new features are added. That is one area where VS falls on its face.

On Jan 27, 2010, at 17:52 PM, Michael Hutchinson wrote:

> On Wed, Jan 27, 2010 at 8:02 PM, Scott Willeke <scott at willeke.com> wrote:
>> I was able to get this working just ran into a copule issues that I was able
>> to workaround. Just including the info for others...
>> I had a problem opening /main/Main.sln in MonoDevelop due to line 1072 that
>> has content "Policies = $0". Removing that line allowed the solution to
> Hm, maybe MD trunk can only be opened by MD trunk. I'm note quite sure
> what change introduced this problem, but it must have been fairly
> recent. If you could file a bug that would be great.
>> load. There was still a problem complaining about not being able to load the
>> "po" project because its type - "TranslationProject" - was unknown.
> You can safely ignore that.
>> After that I encountered a problem building GnomePlatform.cs where it
>> couldn't find the Gnome namespace. Neither could I so I disabled the project
>> as part of the build.
> You should switch to the DebugMac configuration. It includes the Mac
> platform addin, and excludes the Windows and Gnome platform addins.
>> Then I encountered the following:
>> Building: MonoDevelop.Refactoring (Debug)
>> Building MonoDevelop.Refactoring
>> make: *** No rule to make target `all'.  Stop.
>> Eventually I just disabled makefile integration on that project and
>> continued...
>> The same happened for Building: MonoDevelop.HexEditor and I solved in the
>>  same way (disabled makefile integration).
>> Then it ran.
> Oops, those should not have been set to use makefiles for building,
> only for syncing file/ref lists. Fixed in SVN.
> FYI there is a page on the wiki with info about the Mac build process:
> http://monodevelop.com/Developers/Mac_Support/Building_MonoDevelop_on_OS_X
> -- 
> Michael Hutchinson
> http://mjhutchinson.com

More information about the Monodevelop-list mailing list