[MonoDevelop] [BUG] Compiler flag `/noconfig' causes compilation failure on Ubuntu 9.04

Allan Caffee allan.caffee at gmail.com
Tue Sep 15 16:05:43 EDT 2009

On Tue, Sep 15, 2009 at 3:22 PM, Michael Hutchinson
<m.j.hutchinson at gmail.com> wrote:
> On Tue, Sep 15, 2009 at 2:51 PM, Allan Caffee <allan.caffee at gmail.com> wrote:
>> Mono complains that it cannot find the
>> System.Collections.Generic.Stack when I run compilation from within
>> monodevelop.  I found this to be caused by `/noconfig' flag passed to
>> gmcs I was only able to compile after adding the `/noconfig-' flag in
>> the "additional arguments" field.  The bug shows up in version 2.0 of
>> Monodevelop on Ubuntu 9.04.  I haven't actually tried the trunk
>> version but I noticed that the flag is still being unconditionally
>> added to compilation commands in
>> main/src/addins/CSharpBinding/CSharpBindingCompilerManager.cs.  Is
>> there some reason that this argument needs to be here?
> You should add a reference to System.dll. AFAIK all the project
> templates have this already, except the empty project template, which
> is literally empty. Which template did you use?

That explains a lot.  I actually started writing the code from scratch
in Vim which
is why the reference wasn't there to begin with.

> MonoDevelop uses the /noconfig argument to make sure that the C#
> compiler options exactly reflect your project options.

Okay that makes a lot more sense.  That way everything stays
consistent.  I'll add
the includes.  Thank you both for your speedy replies.


More information about the Monodevelop-list mailing list