[MonoDevelop] [BUG] Compiler flag `/noconfig' causes compilation failure on Ubuntu 9.04

Chris Howie cdhowie at gmail.com
Tue Sep 15 15:22:50 EDT 2009

On Tue, Sep 15, 2009 at 2:51 PM, Allan Caffee <allan.caffee at gmail.com> wrote:
> Mono complains that it cannot find the
> System.Collections.Generic.Stack when I run compilation from within
> monodevelop.  I found this to be caused by `/noconfig' flag passed to
> gmcs I was only able to compile after adding the `/noconfig-' flag in
> the "additional arguments" field.  The bug shows up in version 2.0 of
> Monodevelop on Ubuntu 9.04.  I haven't actually tried the trunk
> version but I noticed that the flag is still being unconditionally
> added to compilation commands in
> main/src/addins/CSharpBinding/CSharpBindingCompilerManager.cs.  Is
> there some reason that this argument needs to be here?

/noconfig is added so that the exact references you specify are used,
otherwise gmcs assumes a few, like System.  The problem is that you
are (presumably) referencing corlib, but not System, where this class
lives.  Adding this reference in MD should solve the problem.

Chris Howie

More information about the Monodevelop-list mailing list