[MonoDevelop] multiple monos installed, MonoDevelop can't see all gacs

A.M. Abdelaziz AMAMH3 at Gmail.com
Sat Nov 21 10:04:17 EST 2009

I'm using openSUSE 11.2 x86, GNOME
I have:
mono from rpm svn installed (prefix=/usr)
mono compiled and installed from latest svn (prefix=/usr/local)
MonoDevelop compiled and installed from latest svn, using trunk mono (the
one in /usr/local) as the default .NET runtime

Gtk-sharp and some others are installed to /usr , because I used rpm packs,
compiling from source takes a lot of time

I made my mono (the one in /usr/local, that's compiled from source) able to
see it by setting:
in /etc/profile.local

my problem is:
in MonoDevelop, I can''t see gtk and others under the "packages" tab when
editing references, so I have to add it manually from the ".NET assemblies"
MonoDevelop can see gtk and others when using mono under /usr as the default
runtime, but not the packages installed from source (as they reside in

in short:
is there anyway to make MonoDevelop see all the packages in all GACs and not
only the one associated with the current default mono runtime ?

additional info:
running "echo $MONO_GAC_PREFIX" in the terminal (either as root or user)
gives the right value
I tried "MONO_GAC_PREFIX=/usr monodevelop", no luck,
tried setting gac prefix to just "/usr" in the profile.local file, no luck
nothing in ~/.config/MonoDevelop/log
View this message in context: http://old.nabble.com/multiple-monos-installed%2C-MonoDevelop-can%27t-see-all-gacs-tp26450261p26450261.html
Sent from the Mono - MonoDevelop IDE mailing list archive at Nabble.com.

More information about the Monodevelop-list mailing list