[MonoDevelop] Widgets, Stetic and FocusChain failure

JackBak jbakeman at indra.com
Tue Mar 17 13:51:18 EDT 2009

I have created a dialog much like the MD Project Options dialog with a
treeview on the left and a widget on the right which changes as the user
selects different elements of the treeview. I created the custom widgets
with the MD designer (Stetic) telling MD to create them as widgets. This all
worked perfectly until I tried using the Tab key to walk through the various
elements of my widgets. I can only tab to the first element of my widgets.

In looking into this it appears that MD designer bases my widgets on Gtk.Bin
which according to the Gtk documentation says "GtkBin - a container with one
child". No matter what variation of FocusChain I try I can not get more than
the first element in my widgets selected and the default Gtk behavior (top
to bottom, left to right) with no FocusChain manipulation is identical. Is
it the Gtk.Bin which is causing this?

How else could I do this?

Oh yeah, Mono = 2.4-19.1, MD = 1.9.3-2.2, openSuse 11.1, Gtk# 2.10.3 or Gtk#
View this message in context: http://www.nabble.com/Widgets%2C-Stetic-and-FocusChain-failure-tp22564526p22564526.html
Sent from the Mono - MonoDevelop IDE mailing list archive at Nabble.com.

More information about the Monodevelop-list mailing list