[MonoDevelop] 2.2 startup crash on OS X/ppc (was: Re: MonoDevelop Crashing on Startup)

Michael Hutchinson m.j.hutchinson at gmail.com
Tue Dec 29 22:24:17 EST 2009

On Wed, Dec 23, 2009 at 4:50 PM, Stefan Pohl <pohl at syssoft.uni-trier.de> wrote:
> I have exactly the same Problem as the poster starting this thread. Maybe I
> can add some more details on that problem. The Console error messages I got
> are identical to those already provided by Mark Materna, so I wont repeat
> them.
>> There is no user "michael"on my system.
> Actually that username appears in all stacktrace lines mentioning
> file-paths. I guess "michael" was the person doing the MonoDevelop build and
> simply got his username engraved in the debugging symbols.

Correct, that was me :)

> Mono was installed from: MonoFramework-2.6.1_1.macos10.novell.ppc.pkg (I had
> also tried the universal variant instead of the ppc one, but it didn't make
> any difference)
> MonoDevelop was installed from: MonoDevelop-2.2.dmg (but SystemProfiler
> lists it as Version 2.1.1)

Hm, maybe the application's Info.plist didn't get updated. but the 2.2
dmg is definitely the 2.2. release - you should see the correct number
in the About dialog.

> Both the FAQ on the MonoDevelop website and the Notes.rtf acompanying the
> Mono install package claim that MonoDevelop was included with the Mono
> package, but I couldn't find it after installing Mono, so I had to resort to

Nope, it was removed some time ago. I guess someone forgot to update
those bits of information. I've fixed the FAQ.

> installing it from above mentioned diskimage. I even tried to compile MD
> from source, but the configure script fails to find the installed (and
> working!) mono.

The MD configure script uses pkgconfig to detect the Mono version,
which requires the C SDK package -- weird requirement, I know, but the
autotools build system is a pain to work with. You may find this page

> Has anyone any clues where to go from here? Maybe there are some aditional
> steps that have to be taken to get MonoDevelop up and running on a plain
> vanilla MacOS X system?

Unfortunately, I'm pretty sure your issue is PPC-specific, and I don't
have a PPC machine. My replies to other users with this issue mention
a possible workaround.

Michael Hutchinson

More information about the Monodevelop-list mailing list