[MonoDevelop] 2.2 startup crash on OS X/ppc (was: Re: MonoDevelop Crashing on Startup)

Stefan Pohl pohl at syssoft.uni-trier.de
Wed Dec 23 16:50:31 EST 2009


I have exactly the same Problem as the poster starting this thread. Maybe I
can add some more details on that problem. The Console error messages I got
are identical to those already provided by Mark Materna, so I wont repeat

Mark Materna wrote:
> I'm trying to use MonoDevelop on OS X, and it's crashing on start up. I've
> installed Mono and Monodevelop for OS X as noted on the  MonoDevelop web
> site.   I can't tell if I have Gtk# on my system, but I thought that it's
> included with the Mono framework.  
I was able to compile and run the sample GUI programs (for both GTK# and
Forms) listed at  http://www.mono-project.com/Mono_Basics
http://www.mono-project.com/Mono_Basics , so that doesn't seem to be the

Mark Materna wrote:
> The one thing that struck me is that there is one message that has the
> wrong user name: 
> 12/21/09 12:18:06 PM [0x0-0x4f04f].com.ximian.monodevelop[4270]   at
> MonoDevelop.Components.Docking.DockFrame.SetVisible
> (MonoDevelop.Components.Docking.DockItem,bool) [0x00077] in
> /Users/michael/Mono/monodevelop-2.2/main/src/core/MonoDevelop.Dock/DockFrame.cs:356 
> There is no user "michael"on my system.
Actually that username appears in all stacktrace lines mentioning
file-paths. I guess "michael" was the person doing the MonoDevelop build and
simply got his username engraved in the debugging symbols.

My system configuration:
  Model Name:	Power Mac G4 (AGP graphics)
  Model Identifier:	PowerMac3,1
  Processor Name:	PowerPC 60?  (2.2)
  Processor Speed:	2 GHz
  Number Of CPUs:	1
  L2 Cache (per CPU):	1 MB
  Memory:	1,5 GB
  Bus Speed:	100 MHz
  Boot ROM Version:	4.2.8f1

  System Version:	Mac OS X 10.5.8 (9L31a)
  Kernel Version:	Darwin 9.8.0

Mono was installed from: MonoFramework-2.6.1_1.macos10.novell.ppc.pkg (I had
also tried the universal variant instead of the ppc one, but it didn't make
any difference)

MonoDevelop was installed from: MonoDevelop-2.2.dmg (but SystemProfiler
lists it as Version 2.1.1)

Both the FAQ on the MonoDevelop website and the Notes.rtf acompanying the
Mono install package claim that MonoDevelop was included with the Mono
package, but I couldn't find it after installing Mono, so I had to resort to
installing it from above mentioned diskimage. I even tried to compile MD
from source, but the configure script fails to find the installed (and
working!) mono.   

Has anyone any clues where to go from here? Maybe there are some aditional
steps that have to be taken to get MonoDevelop up and running on a plain
vanilla MacOS X system?

Thanks in advance,

Stefan Pohl

View this message in context: http://old.nabble.com/MonoDevelop-Crashing-on-Startup-tp26878449p26907883.html
Sent from the Mono - MonoDevelop IDE mailing list archive at Nabble.com.

More information about the Monodevelop-list mailing list