[MonoDevelop] Add-in ProjectBinding failed

Thomas Krieger p.o.k at web.de
Fri Apr 10 06:23:32 EDT 2009


i solved the problem now it works fine. Seems that the Namespace was the
cause. After i changed everything to monodevelop
the extension path are found. But it is possible to use some other



Thomas Krieger schrieb:
> Hi, 
> i had some more experiments with the add in architecture and found some strange behaviour. When i try to load my given
> add-in with these extension points:
>     <Extension path = "/MonoDevelop/ProjectModel/ProjectBindings">
>         <ProjectBinding id = "MonoModeller.ModelProject" class =
> "MonoModeller.ModelProject" />
>     </Extension>
>     <Extension path = "/MonoDevelop/Ide/ProjectTemplates">
>         <ProjectTemplate id = "UMLProject" resource = "UMLModel.xpt.xml"/>
>     </Extension>
> an WARNING is thrown that none of the given Extension Point is defined. If i start the ide the second time the warning disappears.
> If i look at the "Add-In Manager" inside of monodevelop the add in is listed an activated. But the Template is not shown inside the "New Project" Dialog.
> Probably there is some problem with the correct queueing of the add in on startup, or do i missing something. I am a newbie to Add-In Architecutre of 
> Monodevelop so hoply someone can help.
> Regards 
> Kiff
> _______________________________________________
> Monodevelop-list mailing list
> Monodevelop-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/monodevelop-list
-------------- next part --------------
A non-text attachment was scrubbed...
Name: p_o_k.vcf
Type: text/x-vcard
Size: 282 bytes
Desc: not available
Url : http://lists.ximian.com/pipermail/monodevelop-list/attachments/20090410/04940a71/attachment-0001.vcf 

More information about the Monodevelop-list mailing list