[MonoDevelop] compiling monodevelop

Lluis Sanchez Gual lluis at novell.com
Thu May 22 20:18:39 EDT 2008

El dj 22 de 05 del 2008 a les 16:08 -0700, en/na asanlua va escriure:
> hello,
> I am trying to compile MonoDevelop in a VMWare Virtual Machine openSUSE
> 10.3, downloaded from the downloads section of the mono project web. In this
> machine, I have downloaded with subversion the revision 103600 of mono, the
> 1.9 version; the revision 103596 of mcs; the revision 103590 of the debugger
> and I compiled all of them succesfully. 
> When I downloaded the revision 103664 of monodevelop and I tried to compile
> it, I found the following error message (translated from spanish to
> english):
> "there is no rule to buid the target 'md1format.xml', needed to
> '../../../build/AddIns/NUnit/MonoDevelop.NUnit.dll'
> I also tried:
> ./configure --disable-nunit
> as I read somewhere, but disable is an unknown argument.
> What can I do??

That MonoDevelop revision does not compile, you have to get a more
recent one, although my advice is that you take the MonoDevelop 1.0
tarball, since SVN is undergoing many changes right now.


More information about the Monodevelop-list mailing list