[MonoDevelop] Running configure under Cygwin in Windows - "Can't find 'mono' in PATH"

Christian Hoff christian_hoff at gmx.net
Sat Dec 20 06:56:18 EST 2008

Maybe that problem occurs because mono has the filename extension .exe 
in Windows and its name is therefore mono.exe, but the configure script 
is just looking for a file named "mono" as it would be present on Linux 

However I haven't tried to build mono on Windows yet; this is just what 
I am guessing.

Are you familar with the export command? Running "export -p" in a cygwin 
shell will give you the PATH environment variable that the configure 
script evaluates. What are the contents of it? Does PATH contain the bin 
directory of the mono installation where mono.exe is? If not, you can 
also set the PATH manually for this session by typing export 
PATH="/cygdrive/c/program files/mono-2.0/bin:....."


Huk wrote:
> Thank You for reply - I restarted Windos but it didn't change anything -
> configure still doesn't see mono in PATH... - I even tried compiling old
> monodevelop-1.0 (1.9?) but same thin here no "mono" in PATH - any other
> Ideas? Maybe I should try compiling mono myself?
> Best regards.
> James
> P.S
> Sorry for my English - it's not my native language ;]

More information about the Monodevelop-list mailing list