[MonoDevelop] bug in monodevelop make?

Kenneth D Weinert kenw at quarter-flash.com
Tue Nov 27 08:06:00 EST 2007

What's happened here is that there is a variable in the makefile that
doesn't have a value so when it's expanded, it expands to nothing.

Take a look in the makefile in /home/simi/app/monodevelop/po and look
for the line that starts with  

file=`echo cs|

and you'll see between the last "&&" and the -o a variable (it start
with a '$' character (like $CC). That variable is the one that's not
getting assigned to.

It does imply that a) you don't have everything installed that you need;
and b) that either you didn't run the ./configure step properly or the
configure script doesn't catch a missing tool.

Hope this helps.

On Tue, 2007-11-27 at 01:09 -0800, Ploscariu Simion wrote:
> Hi i am sorry for your time but i have a problem
> compiling monodevelop, i tried to solve this on linux
> and Ubuntu IRC chanels but i got the answer that is a
> bug in monodevelop.
> The problem appears when i try to install from source
> code, when i execute make the message will eventual
> appear:
> make[1]: Entering directory
> `/home/simi/app/monodevelop/po'
> file=`echo cs | sed 's,.*/,,'`.gmo \
>           && rm -f $file &&  -o $file cs.po
> /bin/sh: -o: not found
> make[1]: *** [cs.gmo] Error 127
> make[1]: Leaving directory
> `/home/simi/app/monodevelop/po'
> make: *** [all-recursive] Error 1
> I compiled this before and worked perfectly, after
> reinstaling ubuntu and try to reinstall monodevelop
> this problem appeared. The people on IRC said that is
> a bug that the program does not report the correct
> error(is true that i had mono installed and the
> configure report the error that i do not have mono
> installed, i had mono installed but other packeges are
> missing, in ubuntu mono is partioned in many small
> packages and is hard to install them all.
>       ____________________________________________________________________________________
> Be a better pen pal. 
> Text or chat with friends inside Yahoo! Mail. See how.  http://overview.mail.yahoo.com/
> _______________________________________________
> Monodevelop-list mailing list
> Monodevelop-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/monodevelop-list
Ken Weinert

Please avoid sending me Word or PowerPoint attachments
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.ximian.com/pipermail/monodevelop-list/attachments/20071127/1cfe6778/attachment.bin 

More information about the Monodevelop-list mailing list