[MonoDevelop] Adding libraries

Dan Smithers dsmithers at talktalk.net
Fri Nov 16 06:48:57 EST 2007

I didn't realise I was so far behind - Ubuntu 7.10 is only distributed
with MD 0.14. I've just upgraded to MD 0.17 and I'll see how it goes.

Thanks for your help.


Lluis Sanchez wrote:
> El dj 15 de 11 del 2007 a les 17:12 +0000, en/na Dan Smithers va
> escriure:
>> I have been doing some more fiddling with this.
>> The code that builds (but doesn't run) is a console App
>> I can't OK changes to the "edit references" pane for a GTK# application.
>> I tried with a brand new project and got the same result.
>> I am running Ubuntu 7.04 with MonoDevelop 0.12
>> I select Edit References and choose the .NET assembly tab. navigate to
>> my library and select Add.
>> Click OK and I get a dialog box which reads
>> Error while executing command: Edit References...
>> if I expand the details then there is a whole stack of exceptions headed by
>> Exception occurred: Exception has been thrown by the target of an invocation
>> System.Reflection.TargetInvocationException: Exception has been thrown
>> by the target of an invocation. ---> System.NullReferenceException:
>> Object reference not set to an instance of an object.
>> Any clues here?
> I fear I can't help much if you are using MD 0.12, which is more than
> one year old. MD has changed a lot since then.
> Lluis.

More information about the Monodevelop-list mailing list