[MonoDevelop] Adding libraries

Dan Smithers dsmithers at talktalk.net
Thu Nov 15 12:12:09 EST 2007

I have been doing some more fiddling with this.
The code that builds (but doesn't run) is a console App

I can't OK changes to the "edit references" pane for a GTK# application.
I tried with a brand new project and got the same result.

I am running Ubuntu 7.04 with MonoDevelop 0.12

I select Edit References and choose the .NET assembly tab. navigate to
my library and select Add.
Click OK and I get a dialog box which reads
Error while executing command: Edit References...

if I expand the details then there is a whole stack of exceptions headed by

Exception occurred: Exception has been thrown by the target of an invocation

System.Reflection.TargetInvocationException: Exception has been thrown
by the target of an invocation. ---> System.NullReferenceException:
Object reference not set to an instance of an object.

Any clues here?


Lluis Sanchez wrote:
> El dj 15 de 11 del 2007 a les 11:34 +0000, en/na Dan Smithers va
> escriure:
>> Thanks Lluis,
>> When I wrote resources, I really meant references. The GUI that I have
>> been developing seems to have problems importing libraries as .NET
>> assemblies and displays an error when I try to do it.
>> I have now tried on an even smaller test and it compiles - but doesn't
>> run as it can't find methods in System.Net.Sockets which don't seem to
>> be included by default nor available in the Edit References pane.
> The System.Net.Sockets namespace is implemented in the "System"
> assembly. You can select it in the references dialog.
>> thanks
>> dan
>> Lluis Sanchez wrote:
>>> El dj 15 de 11 del 2007 a les 03:24 -0500, en/na dsmithers at talktalk.net
>>> va escriure:
>>>> Hi,
>>>> I am really struggling trying to add extra libraries to a monodevelop
>>>> GUI app that I have developed.
>>>> I have written a socket wrapper class and compiled this using make and
>>>> gmcs  on the command line.
>>>> I want to use this in a GTK# GUI that I have constructed using
>>>> monodevelop but can't get it to be seen by the compiler.
>>>> I have tried adding it as a resource, and adding it as a member of the
>>>> solution (copying the library).
>>>> I tried using DllImport with a wrapper for the wrapper.
>>>> I have also changed it so that it is a C# assembly and even tried
>>>> adding it to the GAC.
>>>> I get the Type or namespace name can't be found error.
>>> You have to add a reference to the assembly. In the project tree right
>>> click on the References node and select Edit References.
>>> Lluis.
>> _______________________________________________
>> Monodevelop-list mailing list
>> Monodevelop-list at lists.ximian.com
>> http://lists.ximian.com/mailman/listinfo/monodevelop-list

More information about the Monodevelop-list mailing list