[Mono-winforms-list] Missing Gtk Library on OSX-X11

Peter Dennis Bartok peter at novonyx.com
Mon May 8 01:22:05 EDT 2006

We use this lib only to retrieve the default colors for the UI (to integrate 
with the GNOME desktop). It is not an error, just a hint. I don't expect it 
to help with alpha blending. You might have to file a bug for that.


-----Original Message-----
From: "Don Edvalson" <don at edvalson.net>
To: <Mono-winforms-list at lists.ximian.com>
Date: Sunday, 07 May, 2006 14:09
Subject: [Mono-winforms-list] Missing Gtk Library on OSX-X11

>I have been running my WinForms app under X11 on OSX. It actually runs
>amazingly well considering that it is a fairly complex game. But I am
>running into one thing that I have not found in the documentation and I
>am hoping someone can give me a pointer in the right direction.
>When I run my app, I get the following error message on the Xterm where
>I start it:
>Gtk not found (missing LD_LIBRARY_PATH to libgtk-x11-2.o.so?), using
>built-in colorscheme
>So I tried to find this library, and I can't seem to figure out how to
>find, download, or build it. My app is running fairly well even with
>this message, but I am having a few problems with drawing alpha blended
>images that I suspect might be helped by this. So can anyone point me to
>some documentation regarding where to obtain or build this library?
>Thanks in advance,
>Mono-winforms-list maillist  -  Mono-winforms-list at lists.ximian.com

More information about the Mono-winforms-list mailing list