[mono-vb] Mono 2.6.3 and performance

Quan quandary82 at hailmail.net
Mon Apr 26 06:51:07 EDT 2010

On 20.04.2010 23:06, Stifu wrote:
> PS: I'm on openSUSE, and like it very much. I've had fewer problems with it
> than with Ubuntu (where I sometimes had graphics / sound driver issues,
> depending on the computer). On top of that, openSUSE has a Mono version that
> is up to date, no need to compile from sources to get the latest version or
> anything (since both openSUSE and Mono come from Novell).

OK, let's clarify what I understand under better:
OpenSuse vs. Ubuntu:
I installed OpenSuse 11.2 on a HP HDX 18 4 GB RAM and 2 GHz x64 
Dual-core processor, NVIDIA GForce 9600 GM
and Ubuntu 10.04 on a Dell Inspiron 1300, 1 GB RAM, 1.6 GHz x32 
Processor, Intel 915 GM

Step 1, Installation:
OpenSuse: 4 GB  DVD image to download. 4 GB, wtf, no CD image available 
? (1h50min download)
Ubuntu:    1 CD Image to download, 700 MB (19min 15 sec download)
So in defiance of anyway overrated CD and DVD usage, I choose PXE 
Netboot for Ubuntu (30 MB), downloaded the PXE image. That means no 
burning of a CD image required
OpenSuse: Read the howto: How to create an OpenSuse PXE image (wtf ? 
Have to do it myslef ? With no example ? If I wanted to customize, I 
would have chosen Debian anyway. Well I guess I could have taken Ubuntu 
as reference, if I had some hours to spare)

OK, I downloaded the DVD. Burned it? No, error twice, 2 DVD's trashed, 
didn't work...
So I choose OpenSuse netinstall. Burning a CD image required.

OpenSuse: I like ext4, especially that you can't access it from anywhere 
else than a recent ext4 enabled Linux. So, how about making it possible 
to change the boot and root filesystem to anything else than ext4, like 
XFS/ext3 for example ?
Ubuntu 10.04: Crash on install? Restart, tried again, worked. Well, it's 
Ubuntu testing after all. The file system selection dialog strikingly 
reminds me of Fedora, where you have the choice from a dropdown, but 
when you change, you realize the system forbids it.

OpenSuse: What takes soooooooooooooo long ? Download of unneeded 
packages ? Well fortunately it was Saturday, so I just left it running 
while I went to sleep.

Post installation:
- Enable the root account:
Ubuntu 10.04: Not necessary, enabled by default (change from 9.10), 
9.10, click on system->login->security->enable root account or change in 
gdm.conf, or change kdmrc
OpenSuse: No documentation ? Hints on the web outdated. Have to locate 
kde config file with locate. WTF, 4GB install, but locate not installed ?

-Enable video/sound codecs:
Ubuntu: apt-get install ubuntu-restricted-extras vlc mplayer totem-xine
OpenSuse: zypper: vlc not found, mplayer not found, totem-xine not 
found, codecs in general not working.
(after enabling other repositories, manually recompiling vlc (vlc cannot 
run as root), I at least can use vlc, but mplayer is still not working)

which brings us to
- downloading and compiling a program from source:
Ubuntu: apt-get build-dep <packetname>, apt-get source <packetname>, 
configure, make, make install, -> perfect, compiles a the first try 
(takes about 3 minutes)
OpenSuse: Please go to the respective websites/svn, download the code, 
figure out all dependencies, install them manually, hope it works, ... 
(takes about an hour)

-enabling additional repositories:
Ubuntu: On console, type: deb http://www. ...
OpenSuse: go to /etc/zyp/repos.d/ duplicate an existing file, replace 
contents with info from websites, save, etc.

-searching for packet when offline (e.g. while I drive home from work in 
Ubuntu: apt-cache search <packetname> --> list of searched for packages
OpenSuse: zypper search <packetname>  --> checking for repository... 
repository not found, repository not found, repository not found  [how 
about checking for an internet connection first?]

- installing a usable browser (google chrome):
Ubuntu: Easy ! Download, double click the .deb package, click on 
install. Don't even need to fire up the command line.
OpenSuse: WTF, error, LSB not installed ? 4GB, but not LSB? LSB: Linux 
standard base...
[ok, installed LSB , then installed Google-chrome, and it worked, but an 
average user would have quitted long before now]

- Checking/installing graphics driver:
Ubuntu: glxinfo | grep "direct rendering" --> direct rendering: yes
OpenSuse: glxinfo: command not found...  4 GB - no comment on that --> 
zypper install mesa-utils, glxinfo | grep "direct rendering" --> direct 
rendering: no...
documentation on installing legacy mesa libraries, anyone ? Well, with 
the help of a debian helppage, I was able to figure out the OpenSuse 
mesa library names.
(actually, this point and what is to come is unfair, because as said, 
Intel works, while NVIDIA doesn't, and Ubuntu 10.04 doesn't even install 
[with the graphical install] on the NVIDIA computer)

So I tried to get OpenGL to work with NVIDIA/ATI:
Ubuntu: Ask on ubuntuforums.org:
< 10.04: apt-get install envyng-gtk, envyng -> select 
manufacturer/installation method -> then installs the driver for you, 
and makes the necessary configuration changes
10.04: apt-get install jockey (superseeds envyng)
OpenSuse: Any forum with an answer within 5-10 minutes ? No.
OK, download the correct LINUX driver from NVIDIA, install/compile.
Cannot install the driver in graphical mode. No problem, I know how to 
solve that: init 3
Again, average user would have quitted by now.
OK, compiling/installing now.
WTF? Make sure your kernel was compiled with the version of gcc on your 
computer ?
Well I understand why, but since you install the driver once you install 
the computer, it's most-likely that a kernel was never ever compiled 
with the version of gcc on that computer...
OK, I just try. It might work after all, so I (thought) I could skip 
recompiling the kernel myselfs.
OK, compiling finished successfully, and the driver is installed.
So restart.
OK, restarted and logged in again.
glxinfo | grep "direct rendering" --> direct rendering: yes
OK, so I check by starting google-earth. OK GL works. Close it again.
But two minutes later, X crashes X. CTRL + ALT + BACKSPACE not working ?
OK, uninstall NVIDIA, reconfigure X. How to reconfigure X? Well, on 
debian dpkg-reconfigure xorg , but on OpenSuse?
Well, found out: X -configure, cp xorg.conf /etc/X11/xorg.conf...
BTW, nvidia driver install modifies Xorg.conf ? Hello ? NVIDIA, ever 
heard of HAL ? We write the year 2010 after all.

OK, uninstall the driver, restart. Everything works fine again.
Mmmh, perhaps I have to install a newer kernel, compile it myself, so I 
get the correct kernel and header files for this compiler.
How to compile a kernel on OpenSuse? Well, fortunately I know how to do 
it on Debian, which is why I didn't follow the first howto...
OK, with the help of google, no problem. Compiled my own kernel (ETA: 1 
OK restart with new kernel, sound gone. Know that from Ubuntu, well 
recompile ALSA, restart. Sound works again.
[PS: Also before I recompiled ALSA: PCM switched to 0, so I don't hear 
flash by default, but everything else I hear... guess how long it took 
to figure that out - 15 min.]
OK now recompile the driver, and install, restart.
Now it works for 5 minutes, then it crashes.

Realizing: OK, the system is probably screwed up by now.
So I reinstall OpenSuse entirely.
Now, on the second try, before installing anything else, I install 
OpenGL. After all, I might have to completely reinstall again.

OK this time: Isn't there anything like envyng for OpenSuse:
Searching google, I get to the video driver install howto page for OpenSuse.
Wow, now that would have been nice to know before all that.
OK, installed the NVIDIA driver installer for 11.2, installed, enabled 
the required repos, downloaded and installed.
No error, fine so far, restart.
Again, logging in into X, but crashes 2 minutes later...

Well, guess I have to give up on OpenGL for OpenSuse...
OK, now let's uninstall the NVIDIA driver again.
WTF, how to uninstall... No uninstall.
OK, reconfigure X again.
Copy the Xorg.conf to /etc/X11.
Wanting to do that, I realize: Oh crap, there is no xorg.conf file 
generated by this installer, so creating one will probalby not disable 
the driver...
Restart, fu** yes, now I can't uninstall.

Obviously not possible to install OpenGL here.
OK, reinstall OpenSuse from scratch...
Recompile vlc,  etc.
Fortunately I've documented everything I've done, so I'll be faster this 

This brings us to the installed software version:
Ubuntu:     mono --version: 2.4.3
OpenSuse: mono --version: 2.4.3
Hello? Mono 2.6 is stable. No comment, on both distributions, as well as 
all other distributions out there (except Gentoo)

OK, now let's try whether it can play mp3's. Do I have mp3's? No, so 
let's quickly download some testvideo from youtube.
OK, downloaded, now let's use soundkonverter to convert the video into 
an mp3.
Ubuntu: apt-get install soundkonverter
OpenSuse: zypper search soundkonverter --> not found (with all 
repositories enabled)
ffmpeg, has anyone seen the necessary repo? (well with google I found it)
OK, get the soundkonverter source. Install the dependencies. fine. 
Configure. Automake version to low. Well, 11 < 10 ?
(if you want to compile soundkonverter on opensuse 11.2, also install an 
older version of automake from GNU after you got all dependencies)
OK, now configure worked, try make: Compile error (new compiler version, 
need to add include stdlib/stdio in two header files)
OK, now it compiled. Starting it, OK GUI loaded. Now I try to convert: 
Standstill, it's not doing anything.
OK, google a ffmpeg howto, found, try with first variant: segmentation fault
OK, google again, found second variant, try, converts, ffmpeg crashes at 
the end of conversion, but the generated mp3 file works...
BTW: Found mp3ify.com, a really LOL site, with witch you can directly 
convert youtube videos to mp3...
I suppose they use ffmpeg as backend, but obviously not on OpenSuse, 
because it wouldn't work, then.
OK, mp3 sound works, delete mp3.

I just wonder, why can Ubuntu 10.04 (Ubuntu testing!) on a 1.6 GHz x32 
single-core processor with 1 GB RAM be faster than OpenSuse
on a 2 GHz x64 Dual core processor with 4 GB RAM ? Well, that might have 
something to do with KDE (OpenSuse default setting)...

So from what I can see:
Install download time: Ubuntu is the all-variants winner anyway
Install time: Ubuntu is the clear winner
Speed: Ubuntu is the clear winner
Mono: No difference
Monodevelop: no difference
Multimedia: very well on Ubuntu, but not really working on OpenSuse
Browser: Google chrome just rocks, on both distros. Never no more 
FireCrap. Oh btw, Google-chrome Java support on OpenSuse, has anybody 
seen it ? Well, I guess I could probably figure it out if I still wanted 
Packet management: Let's just say that nothing can really compete with 
apt. Basta! That includes zypper.
Source packet managment:  I think it is be better for OpenSuse if I 
don't mention it.

Now, comparing the user experience:
Well, I can't really compare them, since my OpenSuse crashes about every 
5 minutes.
That's hardly enough time to collect an experience. Well, it's also an 
experience, but not a good one. All I can say is that the KDE experience 
was pretty awful.
The only thing I can tell is I can't install OpenSuse on the 
Inspiron1300 laptop for an equal comparison, because that laptop is too 
slow for OpenSuse [well it installs, but it isn't really usable].
Hello ? 1 GB RAM, 1.6 GHz, too slow ? With my DSL distro, I run my 
PostGre SQL database on a 260 MHz ARM CPU with 64 MB RAM, and it is 
stable, and works fine and fast for almost 120 users...

So, this is MY opinion.
If anybody disagrees, feel free to flame me now with anything where I am 

Kind regards

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-vb/attachments/20100426/4db7692e/attachment.html 

More information about the Mono-vb mailing list