[Mono-osx] Registry permissions issue

Tufnell mattlaver at gmail.com
Fri Aug 24 21:52:47 UTC 2012

I've got a mono application that uses a Windows .Net developed library that
has an unfortunate side effect in that it reads and writes a key to the

Now my application runs fine on OS X if I run it as an administrator (sudo
from the terminal) but as a regular user or from Mono Develop it falls over
with a System.UnauthorizedAccessException

But it's worse than that as this exception doesn't get caught by my global
try catch code which surrounds the call to the library which is a shame.

Is there a way to authorise access to the registry key in mono?

I've tried changing the security on the registry directory itself using
"chmod 755 registry"

Any suggestions would be great.

View this message in context: http://mono.1490590.n4.nabble.com/Registry-permissions-issue-tp4656389.html
Sent from the Mono - OSX mailing list archive at Nabble.com.

More information about the Mono-osx mailing list