[Mono-osx] How can a custom library be included in a package.

JasonZ jzwolak at vt.edu
Fri Feb 4 17:23:07 EST 2011

K, I downloaded Mono 2.8.1 and mmp runs now.  But no matter what arguments I
give it, I get the output below.  I tried copying the command from
MonoDevelop, which explicitly included several Mono libraries with the '-a'
flag.  That didn't work, so I experimented with different arguments, but
apparently pkg-config is being called and cannot find mono.  I determined
that the pkg-config from /opt was being used (from Mac Ports).  But the
pkg-config in /Library/Frameworks/Mono.framework/Versions/2.8.1/bin/ should
be used, and it wasn't in my path... So for this project I added it to my
path, but I'm a bit concerned about this, because this pkg-config may not
work with other libraries that need pkg-config...  But mmp seems to be
working okay now. However, I get some strange error when I run my app...
I'll look into more and let you know if I have more questions.

jason-zwolaks-macbook-pro:temp jzwolak$ mmp main.exe
Process exited with code 1, command:
pkg-config --variable=prefix mono-2

Unhandled Exception: System.IO.DirectoryNotFoundException: Directory
'/lib/mono/4.0' not found.
  at System.IO.Directory.ValidateDirectoryListing (System.String path,
System.String searchPattern, System.Boolean& stop) [0x00000] in <filename
  at System.IO.Directory.GetFileSystemEntries (System.String path,
System.String searchPattern, FileAttributes mask, FileAttributes attrs)
[0x00000] in <filename unknown>:0 
  at System.IO.Directory.GetFiles (System.String path, System.String
searchPattern) [0x00000] in <filename unknown>:0 
  at MonoMac.Bundler.MonoMacResolver.DirectoryGetFile (System.String
directory, System.String file) [0x00000] in <filename unknown>:0 
  at MonoMac.Bundler.MonoMacResolver.SearchDirectory (System.String name,
System.String directory) [0x00000] in <filename unknown>:0 
  at MonoMac.Bundler.MonoMacResolver.Resolve
(Mono.Cecil.AssemblyNameReference reference) [0x00000] in <filename
  at MonoMac.Bundler.Driver.ProcessAssemblyReferences
(Mono.Cecil.AssemblyDefinition assembly) [0x00000] in <filename unknown>:0 
  at MonoMac.Bundler.Driver.GatherAssemblies () [0x00000] in <filename
  at MonoMac.Bundler.Driver.Main (System.String[] args) [0x00000] in
<filename unknown>:0 

View this message in context: http://mono.1490590.n4.nabble.com/How-can-a-custom-library-be-included-in-a-package-tp3256437p3261140.html
Sent from the Mono - OSX mailing list archive at Nabble.com.

More information about the Mono-osx mailing list