[Mono-osx] Building libgdiplus on OS X

Lee V.Andrus landrus2 at by-rite.net
Mon Jun 1 15:17:31 EDT 2009

I have had the same problem with building the latest source from the  
Subversion repository.  The utility "aclocal" cannot find several  
".m4" files containing the definitions of macros referenced by  
"configure.in" that are supposed to enable "configure" to determine if  
various packages are present.  So the raw text of some  
"PKG_CHECK_MODULES" macro references wind up in "configure", where  
they do no good.  Various methods can be used to tell aclocal where  
additional files are, including defining environment variable  
ACLOCAL_FLAGS="-I /another/folder/containing/m4/files" when running  
"autogen.sh" or putting the folder pathnames in file "/usr/share/ 
aclocal/dirlist", one per line.  type "info aclocal" in a Terminal  
window for more info on aclocal.  Unfortunately, I have not been able  
to find the missing ".m4" files for "xlib", "xlib_xrender", "xcb",  
"png", "glitz", "GLITZ_AGL", "GLITZ_EGL", "GLITZ_GLX", "GLITZ_WGL",  
"directfb", "FONTCONFIG", "FREETYPE", "POPPLER", and "LIBRSVG".  And  
that is after I installed the "fontconfig" and "freetype" packages.   
Does anyone know where they can be found?

On another sour note, why does libgdiplus forbid its internal cairo  
from using Quartz Fonts?  I would think that using the native package  
would produce better performance, better compatibility with other Mac  
GUI functions, and maybe reduce the number of packages one needs to  
install.  But I found this in libgdiplus/configure.in:

# gdiplus mac note; if we have quartz and ft fonts, quartz is the  
default and gdi+ assumes the latter everywhere, force it out
# of the internal build
	ac_configure_args="$ac_configure_args --disable-quartz-font"

> Alex Shulgin alexander.shulgin at yessoftware.com
> Mon Jun 1 08:53:18 EDT 2009

> Hi,
> I had to built libgdiplus on OS X recently and must admit that this  
> was
> quite an experience.
> So I'd love to see clear instructions from developers how is one
> supposed to do that.  Also, if someone is trying to build it now or
> later this might save him some time.
> Here's the summary of what finally worked for me:
> * Install mono-2.4 framework.
> * Download & unpack libgdiplus-2.4.tar.bz2.
> ...
> I've also tried to build libgdiplus from trunk, but couldn't get past
> configure step.
> Yes, autogen.sh provided in trunk has --with-cairo=internal option  
> (so I
> don't need to hide installed cairo.pc), but configure fails at random
> places while trying to locate dependencies (BASE_DEPENDENCIES, GTK,
> etc.).  Setting ACLOCAL_PATH to current mono installation didn't  
> help me
> with this problem.
> ...
> --
> Regards,
> Alex

More information about the Mono-osx mailing list