[Mono-osx] (no subject)

Jeremy R. Geerdes jgeerdes at mchsi.com
Fri Feb 8 11:11:26 EST 2008

Greetings. I'm wondering if anyone can provide insight into installing  
mono, xsp, and mod_mono on a Santa Rosa MacBook running Leopard  
(detailed system specs below).  I've run the packaged installer, and  
everything seems to go okay, but I have since discovered that even  
simple tests of the framework fail.  I can start xsp and mod-mono- 
server, and they report that they are listening on appropriate  
addresses and ports, but they fail to respond when queried.  And  
mod_mono won't even install at all.  The make install simply places a  
symlink (mod_mono.so) to a non-existent file (mod_mono.0.0.0.so) in  
the Apache modules folder

I read in other forums that modules such as mod_jk have issues with  
Leopard and/or the Santa Rosa architecture because they still try to  
install for i386 when Santa Rosa requires x86-64.  So after several  
frustrating days, I went through the makefile for mod_mono and tried  
to change i386 references to x86-64, but I don't really have a lot of  
experience doing that, and it did nothing for me.

Detailed system specifications:
Hardware: MacBook,3,1
CPU: Intel Core 2 Duo 2.2GHz (Santa Rosa)
OS: Mac OS X 10.5.1
X11:  2.1.0 - X.org X11R7.2
xsp: (I've tried 1.2.6, too)

If you need more information, just let me know!  And thanks in advance  
for any and all assistance!

Rev. Jeremy R. Geerdes, Pastor
Debra Heights Wesleyan Church
4025 Lower Beaver Rd.
Des Moines, IA 50310

p/f: (515) 279-5212
h: (515) 277-7491
jgeerdes at mchsi.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-osx/attachments/20080208/dd2038fc/attachment-0001.html 

More information about the Mono-osx mailing list