[Mono-osx] Problems with opening .wav-files

Christoph Standler Christoph.Standler at gmail.com
Mon Aug 18 10:25:01 EDT 2008


I'm trying to convert our companies software to MAC-OSX (10.5) using the
Mono Framework Preview 1.

I recently encountered a big problem: When I try to read .wav-files, I
always get an IOException, saying that another process is currently using
the file.

I tried to open the files with the File.Open()-, File.Move()-Commands. I
also tried it with a FileStream, all commands with every possible
combination of FileAccess-, FileOpen- and File.Share-Arguments, it didn't
change a bit.

The wave-files I try to access have the right permissions, some of the I
took directly from the mac-installation, some of them were copied from my
windows-pc. I also tried to load them from different locations, started the
software with root-permissions...

Accessing other files like .xml or text-files seems to work perfectly
View this message in context: http://www.nabble.com/Problems-with-opening-.wav-files-tp19032859p19032859.html
Sent from the Mono - OSX mailing list archive at Nabble.com.

More information about the Mono-osx mailing list