[Mono-osx] System.IO.IOException: Too many open files XSP

Sean Hignett seanhig at geminibay.com
Thu Sep 28 09:19:43 EDT 2006

Mostly I run XSP from within Eclipse as an external tool, and I have  
been using it without issue (at least not a major one) on OSX (intel)  
since the macbooks came out.

Last night I went to run my relatively non-trivial ASP.NET app on my  
mac mini (also intel), and after a few pages into the app, I would  
consitently get: System.IO.IOException: Too many open files XSP.

It is XSP 1.1.17 from the package dmg install.

The staketraces didn't appear to follow any pattern, at one point it  
was during a scan of the assemblies bin, at another, not.

System.IO.IOException: Too many open files
   at System.IO.Directory.GetFileSystemEntries (System.String path,  
System.String pattern, FileAttributes mask, FileAttributes attrs)  
   at System.IO.Directory.GetDirectories (System.String path,  
System.String pattern) [0x00000]
   at System.IO.DirectoryInfo.GetFileSystemInfos (System.String  
pattern) [0x00000]
   at System.IO.DirectoryInfo.GetFileSystemInfos () [0x00000]
   at (wrapper remoting-invoke-with-check)  
System.IO.DirectoryInfo:GetFileSystemInfos ()
   at System.IO.KeventWatcher.StartMonitoringDirectory  
(System.IO.KeventData data) [0x00000]
   at System.IO.KeventWatcher.StartDispatching  
(System.IO.FileSystemWatcher fsw) [0x00000]
   at System.IO.FileSystemWatcher.Start () [0x00000]
   at System.IO.FileSystemWatcher.set_EnableRaisingEvents (Boolean  
value) [0x00000]
   at (wrapper remoting-invoke-with-check)  
System.IO.FileSystemWatcher:set_EnableRaisingEvents (bool)
   at System.Web.Caching.CacheDependency..ctor (System.String[]  
filenames, System.String[] cachekeys,  
System.Web.Caching.CacheDependency dependency, DateTime start) [0x00000]
   at System.Web.Caching.CacheDependency..ctor (System.String[]  
filenames) [0x00000]
   at System.Web.Compilation.AspGenerator.GetCompiledType () [0x00000]
   at System.Web.UI.UserControlParser.CompileIntoType () [0x00000]
   at System.Web.UI.UserControlParser.GetCompiledType (System.String  
virtualPath, System.String inputFile, System.Web.HttpContext context)  
   at System.Web.UI.TemplateControl.GetTypeFromControlPath  
(System.String virtualPath) [0x00000]
   at System.Web.UI.TemplateControl.LoadControl (System.String  
virtualPath) [0x00000]

After the error happens once, it keeps repeating itself on every  

When I run XSP from Eclipse on the same machine, it works fine, and I  
can run through a full test suite of the application without ever  
hitting that error.  As soon as I run it outside of eclipse, that  
error happens at exactly the same point.

Is this a common/known/reported issue?

The fact that it works from within Eclipse seems to suggest timing is  
a factor, as I imagine the Eclipse wrapper adds some overhead that  
slows things down....

perhaps it is the unbridled speed of the core duo that is making XSP  
puke :) lol.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-osx/attachments/20060928/e1605d23/attachment.html 

More information about the Mono-osx mailing list