[Mono-list] cannot install 2.10 on centos 6

Edward Ned Harvey (mono) edward.harvey.mono at clevertrove.com
Sat Jun 22 15:50:23 UTC 2013

> From: mono-list-bounces at lists.ximian.com [mailto:mono-list-
> bounces at lists.ximian.com] On Behalf Of Edward Ned Harvey (mono)
> hopefully 3.0.12 tarball will compile for you, as simply as 2.10
> did.

Confirmed this worked for me:

Not saying any of this is strictly necessary.  I'm just documenting what I did, and saying, "worked for me."

Completed in 42 minutes on normal desktop-grade hardware.

I suspect, the only part actually necessary is "yum -y groupinstall base development ; yum -y install sudo" followed by the download of mono sources, and build command.

Starting from Centos Minimal, 6.3 x86_64, fully updated.
yum -y groupinstall base
yum -y install sudo
yum -y install gcc gcc-c++ kernel-devel perl make
wget http://mirrors.syringanetworks.net/fedora-epel/6/i386/epel-release-6-7.noarch.rpm
sudo rpm -iv epel-release-6-7.noarch.rpm
sudo yum -y install policycoreutils-python
sudo yum -y groupinstall debugging development

wget http://download.mono-project.com/sources/mono/mono-3.0.12.tar.bz2
tar xjf mono-3.0.12.tar.bz2
cd mono-3.0.12
time ( ./configure --prefix=/usr/local/mono-3.0.12 && make && sudo make install && sudo ln -s mono-3.0.12 /usr/local/mono)

More information about the Mono-list mailing list