[Mono-list] NUnit and app.config not found under mono

Dave Curylo curylod at asme.org
Mon Sep 24 18:07:13 UTC 2012

I've got a set of tests that I'm running with nunit-console. Those tests
require some configuration settings. When running under .NET on Windows,
I'm able to specify those configuration settings in the app.config file for
the unit test assembly and nunit-console.exe finds them. When running
nunit-console under mono, the configuration settings aren't found.

So for example, I have an assembly containing my NUnit test fixtures named
MyCompany.MyProduct.Tests.dll with settings in the app.config for that
project, which are copied into MyCompany.MyProduct.Tests.dll.config.  On
Windows, I run "nunit-console.exe MyCompany.MyProduct.Tests.dll" and it
runs the tests, finding the config settings.  On Linux (tried both Ubuntu
and CentOS) with Mono, when I run "mono nunit-console.exe
MyCompany.MyProduct.Tests.dll" the tests run as expected but the config
settings are not found.

Oddly enough, nunit under monodevelop seems to overcome this problem and
finds the config, so I'm not sure what's being done differently there. Is
anyone else able to get nunit tests to find their config files when running
under nunit-console?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-list/attachments/20120924/fd22ebb1/attachment.html>

More information about the Mono-list mailing list