[Mono-list] Compiling Mono 3.0.1 on ARM Fails (raspberry pi)

The_Flo florian.grubert at web.de
Wed Nov 14 19:52:20 UTC 2012

You are right, compiling with the option worked better but still failed at
the end saying
mini-arm.h:17:2: error: #error "hardfp-abi not yet supported."

The armhf port for mono 3.0 is still in development and not done yet. There
is a soft float version of wheezy also, probably I'll try to compile mono
3.0 on that one. The initial reason for testing 3.0 was a problem on WCF
with the previous version and I just wanted to know if it was fixed.

MattSwarbrick wrote
> export CFLAGS=-march=armv6k
> This should still fail though, it will say something like: "hardfp abi not
> supported yet", there is an armhf port for mono, so you may need to build
> that. But I'm not sure how to do that yet, let us know how you get on, or
> if you have any ideas regarding the port

View this message in context: http://mono.1490590.n4.nabble.com/Compiling-Mono-3-0-1-on-ARM-Fails-raspberry-pi-tp4657322p4657382.html
Sent from the Mono - General mailing list archive at Nabble.com.

More information about the Mono-list mailing list