[Mono-list] System.Runtime.Serialization missing

Abe Gillespie abe.gillespie at gmail.com
Sat Feb 26 16:06:55 EST 2011

You've found a work-around, but for the health of the Mono project in
general this should be tracked down.  Also, Newtonsoft's JSON
serializer is so incredibly well baked that I hope I can urge you back
to using it.  In fact I've recently run into some WCF serialization
bugs (MS.Net, not Mono) that I categorically replaced all
runtime-provided serialization with JSON.Net.  It works a treat.

Now, about your issues, one thing I've run into with getting the
correct version of Sys.Run.Serialization linked in is Silverlight
assemblies (2.0.5.*) vs. the full runtime assemblies (3.x and 4.x).
Make sure your environments match the correct assembly versions on
both sides - for example, if you are in fact using Silverlight then
you need to drop in the Newtonsoft.Json.Silverlight.dll assembly and
not the Newtonsoft.Json.dll assembly.

A possible other issue is a bug in Mono that's currently affecting at
least some of the serialization infrastructure
https://bugzilla.novell.com/show_bug.cgi?id=669786 ... though for your
specific case I doubt this is the issue.  But, like I said, for the
health of Mono you'll hopefully investigate further.


On Sat, Feb 26, 2011 at 3:54 PM, David Auzinger
<david.auzinger at gmail.com> wrote:
> Ok I solved my Problem by switching to a different JSON serializer
> Regards
> David Auzinger
> 2011/2/26 David Auzinger <david.auzinger at gmail.com>
>> Some Additional Information:
>> When i upload the System.Runtime.Serialization.dll i get the same error
>> again but with System.Data, when i upload the System.Data.dll the runtime
>> crashes ;)
>> But I'm not sure of the mono Verison installed on the sever, so this may
>> be faulted by a version mismatch.
>> Regards
>> David Auzinger
>> 2011/2/26 David Auzinger <david.auzinger at gmail.com>
>>> Hi
>>> (I hope I'm right here. I would have posted this in the mini forums but I
>>> can't access them)
>>> I'm developing on a windows machine with Visual Studio Express 2010 (i
>>> started with monodevelop, but then it kept greying out the Run/Debug options
>>> in the menu and i had to switch). As for my knowledge: I'm quite used to C#,
>>> though no pro, same with linux in general and this is my first mono-project.
>>> A part of the program I'm writing is a deserialization of JSON data. This
>>> is don using JSON.Net. When compiling and running the code on the windows
>>> machine, everything works just fine, on the target machine (a debian server)
>>> however it crashes when i try to use JSON.Net and gives me a message about
>>> System.Runtime.Serialization Assembly could not be found (Assembly:
>>> System.Runtime.Serialization (assemblyref_index=5), Version = Public
>>> Key: b77a5c561934e089)
>>> I would appreciate any help!
>>> Regards
>>> David Auzinger
> _______________________________________________
> Mono-list maillist  -  Mono-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-list

More information about the Mono-list mailing list