[Mono-list] System.Runtime.Serialization missing

David Auzinger david.auzinger at gmail.com
Sat Feb 26 15:54:56 EST 2011

Ok I solved my Problem by switching to a different JSON serializer

David Auzinger

2011/2/26 David Auzinger <david.auzinger at gmail.com>

> Some Additional Information:
> When i upload the System.Runtime.Serialization.dll i get the same error
> again but with System.Data, when i upload the System.Data.dll the runtime
> crashes ;)
>  But I'm not sure of the mono Verison installed on the sever, so this may
> be faulted by a version mismatch.
> Regards
> David Auzinger
> 2011/2/26 David Auzinger <david.auzinger at gmail.com>
>  Hi
>> (I hope I'm right here. I would have posted this in the mini forums but I
>> can't access them)
>> I'm developing on a windows machine with Visual Studio Express 2010 (i
>> started with monodevelop, but then it kept greying out the Run/Debug options
>> in the menu and i had to switch). As for my knowledge: I'm quite used to C#,
>> though no pro, same with linux in general and this is my first mono-project.
>> A part of the program I'm writing is a deserialization of JSON data. This
>> is don using JSON.Net. When compiling and running the code on the windows
>> machine, everything works just fine, on the target machine (a debian server)
>> however it crashes when i try to use JSON.Net and gives me a message about
>> System.Runtime.Serialization Assembly could not be found (Assembly:
>> System.Runtime.Serialization (assemblyref_index=5), Version = Public
>> Key: b77a5c561934e089)
>> I would appreciate any help!
>> Regards
>> David Auzinger
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-list/attachments/20110226/5af30d30/attachment.html 

More information about the Mono-list mailing list