[Mono-list] Unspecific error: System.Exception: Generic Error [GDI+ status: GenericError]

Yves Goergen nospam.list at unclassified.de
Fri Oct 29 12:28:13 EDT 2010

On 28.10.2010 21:23 CE(S)T, Yves Goergen wrote:
> Package versions are:
> mono-runtime   2.4.4~svn151842-1ubuntu4
>    (pretty much everything with mono in it has this version number)
> libgdiplus     2.4.2-1ubuntu0.10.04.1

It's just not getting any better. Today I had access to an OpenSUSE 11.2
box which came with Mono installed. It's got version 2.4.2 of both mono
and libgdiplus installed. The test programme shows the same error there.

I have now uninstalled the libgdiplus package from one of my Ubuntu
Lucid machines, downloaded the same package for maverick and installed
that one, as its dependencies are already met in lucid. The error persists.

I now tried to use the entire Mono stuff from maverick but it's a whole
lot of packages and downloading each of them manually is a pain. Can I
make Aptitude/Synaptic use the maverick package source and then have the
new package mono-runtime with all its dependencies installed without
interfering the running system and package management?

As a last resort I could uninstall all Mono from Ubuntu and use the
vanilla sources to build it myself, but this is a path I'm very
unwilling to go.

Yves Goergen "LonelyPixel" <nospam.list at unclassified.de>
Visit my web laboratory at http://beta.unclassified.de

More information about the Mono-list mailing list