[Mono-list] TypeLoadException After New Install

martin_costello martin_costello at talk21.com
Thu Sep 18 13:01:45 EDT 2008

I've had a nose around and it seems that libgdiplus isn't compiling.  The
latest build and 1.9 give me this error:

/usr/bin/ld: final link failed: Bad value
collect2: ld returned 1 exit status
make[2]: *** [libgdiplus.la] Error 1
make[2]: Leaving directory `/home/martin/libgdiplus-1.9/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/martin/libgdiplus-1.9'
make: *** [all] Error 2

Any ideas?

Tracing the program exception shows the following:

An exception was thrown by the type initializer for System.Drawing.GDIPlus

martin_costello wrote:
> I've just tried installing a daily tarball on my machine that had Mono
> 1.9.1 with:
> ./configure --prefix=/usr/local; make; make install
> Doing
> mono --version
> after the compile finished showed the correct version, but when I load my
> application I get loads of TypeLoadExceptions that I didn't get before.  I
> tried reverting back to Mono 1.9.1, but I'm still getting these problems.
> I'm running Fedora 8 on an amd64 processor, and the architecture shows up
> as amd64 with --version.
> Any one got any ideas on what's going wrong now that wasn't before?
> I'm trying a new build now after explictly uninstalling Mono to see if
> there's been some sort of version mish-mash during the installing, but I'm
> not overly hopeful after 3 attempts.

View this message in context: http://www.nabble.com/TypeLoadException-After-New-Install-tp19556875p19557432.html
Sent from the Mono - General mailing list archive at Nabble.com.

More information about the Mono-list mailing list