[Mono-list] Mono on Windows- Mysql reference error

bhanu2217 bhanu2217 at yahoo.com
Mon Dec 15 07:39:43 EST 2008

I have installed Mono on Windows.

I am using Visual Studio 2005 & Mysql.

I have created a simple program/website to read data from mysql database
using mysql Connection 5.0.9.

The program works fine on windows/iis.

but when i run it on XSP/Mono i get the following error.

CS0246: The type or namespace name `MySql' could not be found. Are you
missing a using directive or an assembly reference? 
Line 10: using MySql.Data.MySqlClient;

->I tried including the assembly details in the web.conf file but it didnt
-> I  run the following things on command promt
cd path_to_your MySql.Data.dll assembly
 gacutil -i MySql.Data.dll
but it didnt work.

->My project doesn't have a bin folder, so i manually created a bin folder
and copied mysql.Data.dll file but it didn't work.

I am still getting the same error.

Please help me out.

Fedora 10
Version information:  
Mono Version: 2.0.50727.42
ASP.NET Version: 2.0.50727.42
Mono Develop Version: 2.0 Alpha1(1.9)
View this message in context: http://www.nabble.com/Mono-on-Windows--Mysql-reference-error-tp21013188p21013188.html
Sent from the Mono - General mailing list archive at Nabble.com.

More information about the Mono-list mailing list