[Mono-list] [mono-list]DLL Import errors

Eric Morgan eric at rengeo.com
Tue Apr 17 15:40:15 EDT 2007

Hey all,

I'm trying to P/Invoke into a library from my csharp code, but I keep getting System.DllNotFoundException errors.

I've double checked my config file and the dllmap is correct.
I've made sure the library can be found in the LD_LIBRARY_PATH environment variable.

Still doesn't work.

I've even successfully added it to the ldconfig cache, rebuilt the cache and mono still can't find the library.  I've also tried pasting the library into every concievable directory that mono could be looking in and it still says the file cannot be found.

I have no Idea what's wrong.  I know the library isn't corrupted, because it passes md5sum.  It could be because the library was built on a 32bit machine, and I'm running a 64bit, but the same library is successfully used on the same computer in a Java application by the developer of the library I'm trying to use.

So, I know the library can run on this machine.  Why could mono be having such a hard time with it?


Eric Morgan 


More information about the Mono-list mailing list